Issue 24889 - Page count field saved or loaded as Page number
Summary: Page count field saved or loaded as Page number
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2004-01-28 23:03 UTC by xordoquy
Modified: 2017-05-20 11:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

File for which the page count in the footer appears as page number (7.13 KB, application/vnd.sun.xml.writer)
2004-01-28 23:05 UTC, xordoquy
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description xordoquy 2004-01-28 23:03:56 UTC

I'm editing a document with openoffice 1.1 (debian/sid).
In the footer, I inserted the page count and page number fields to get page
numbering as: <page number> / <pages count>

When I save, close openoffice, restart and load the document, the pages count
fields appears as page number.

I have tried to reproduce it from a new document but failed. Therefore you'll
send a guilty document to whoever will ask me (or join it if join pieces are

Comment 1 xordoquy 2004-01-28 23:05:48 UTC
Created attachment 12778 [details]
File for which the page count in the footer appears as page number
Comment 2 h.ilter 2004-01-30 15:30:38 UTC
HI->ES: Could not reproduce, maybe you can.
Comment 3 xordoquy 2004-01-30 15:41:02 UTC
If you couldn't reproduce with the joined file you should close the bug.

From a new document, I can't reproduce the bug. But with the joined one it is
reproduced at 100%.
I suspect it's because this document has been imported for openoffice 1.0
Comment 4 eric.savary 2004-01-30 16:04:18 UTC
It appears that can only be reproduced with the French version.
The fields page / page count are correct.
It's only (!!!) the display of Page count which is wrong.

I'll try to find out what's wrong...
Comment 5 eric.savary 2004-01-30 18:08:48 UTC
Ok, I got it (I think)!


First of all, I thought it was a bug in the French build only.
Wrong. It exists in English zoo.

The bug is that the field simply doesn't update on load.
Press F9 and it will be updated.

ES->OS: the update fails due to the combination of settings:
- fields are in a frame which is itself in the footer
- footer is set to "AutoFit Height"
- Frame anchored as character

I could reproduce it from scratch with a new document.

Comment 6 pcolbourn 2004-02-25 00:11:24 UTC
I am using OO writer 1.1.0 (debian/sid).

I added a footer with "Page <page> of <count>" type entry. It seemed to work in
OO writer (the file was saved as MS-Word 97/2000/XP doc format).

I later editted the document in MS-Word 97 (MS-Windows NT 4 + Citrix).

I noticed the page count field was not working. It displayed a constant '1'. eg.
Page 3 of 1. I deleted the field and re-added the page count field in MS-Word
and continued editing.

I then edited the document in OO writer again and noticed that the page count
field was now working.

Opening the document in MS-Word again show the same fault: eg. Page 3 of 1.

MS-Word does not update the page count field until printing or print preview it
seems, so there is no fault.
Comment 7 xordoquy 2004-02-25 06:11:21 UTC
In my case, I never tried to save the document to any other format than sxw.
Moreover, the trouble is a bit different from what your reporting.
The total page field isn't locked to 1 but is the same as the page number.
However, I my case, updating (F9) fixes the total page number field. There's no
need to delete and reinsert it.
Comment 8 Oliver Specht 2004-02-25 07:00:15 UTC
I can't see the need for OOo 2.0 -> set to OOo later
Comment 9 Marcus 2017-05-20 11:22:17 UTC
Reset assigne to the default "".