Status: CLOSED DUPLICATE of issue 19510
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.1.1
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: OOo 2.0
Assignee: mikhail.voytenko
QA Contact: issues@framework
Depends on:
Reported: 2004-04-12 20:33 UTC by jgriffis123
Modified: 2004-07-12 13:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description jgriffis123 2004-04-12 20:33:41 UTC
I get the error "API call exited abnormally" error when I try to open .doc 
or .xls files using IE. Mozilla and Netscape work fine. Regular http seems to 
work fine, but not https. 

I have duplicated this issue and have seen a ton of posts on this.  I have 
tried OOo 1.1.0 and the new 1.1.1.

Place a .doc file on a http webserver.  Try opening it via http link with IE. 
(of course only OOo is installed and IE knows to use OOo to open the doc).  
You should succeed in opening the doc.

Now enable https on that webserver and try the same thing.  You will recieve a 
grey screen with an error that pops up about "API CALL EXITED ABNORMALLY".  

It appears to me that SSL is not supported with OOo and IE.  Can anyone 
confirm or anyone have any additional info?
Comment 1 bbeckstead 2004-04-13 14:36:35 UTC
*** Issue 27705 has been confirmed by votes. ***
Comment 2 jgriffis123 2004-04-14 21:50:22 UTC
I have found that by disabling the IE viewer, you can get open office 1.1.1 to 
open files off a https webserver.

If you have open office installed on your windows xp machine follow the steps 

1- Close open office.
2- Go to start,control panel
3- Add remove programs
4- Chose to modify open office install
5- Under optional components, disable the ActiveX control (right click the 
blue arrow to get a red X)
6- Click modify to continue, finish the rest of the prompts. 
6- Try opening a doc that you could not open previously.

This worked for me, which proves to me that it is the IE activex viewer that 
is causing the issue. I assume the install could be changed to fix this.

Comment 3 h.ilter 2004-04-15 09:14:27 UTC
HI->TM: Please investigate.
Comment 4 thorsten.martens 2004-04-15 09:24:04 UTC
TM->MAV: Please have a look. Don´t exactly know, if an ibis bug for this problem
does already exist.
Comment 5 mmeeks 2004-04-15 15:17:53 UTC

*** This issue has been marked as a duplicate of 19510 ***
Comment 6 mikhail.voytenko 2004-07-12 13:15:34 UTC
So I close the issue.