Issue 40750 - Resaving files on partitions not mounted with parameter"exec" impossible
Resaving files on partitions not mounted with parameter"exec" impossible
Status: CLOSED FIXED
Product: General
Classification: Code
Component: code
OOo 1.1.4
PC Linux
: P3 trivial (vote)
: OOo 1.1.5
Assigned To: thorsten.martens
issues@framework
: oooqa
: 36629 43707 45121 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-16 18:31 UTC by frankverlinden
Modified: 2010-11-10 21:35 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description frankverlinden 2005-01-16 18:31:23 UTC
As described in "http://www.oooforum.org/forum/viewtopic.php?t=14739" it is
possible to get the message "Could not create backup copy" when saving to an nfs
server which is not mounted in fstab with the option exec under SuSE 9.2.

The real problem is that OpenOffice is not saving the document at all. The
message suggest it could not create a backup copy (an option when saving which
was not set in my environment). This may lead to the loss of data.

The error message should be replaced by something like "Could not save document"
which will alert the user immediately that there is something really wrong.
Comment 1 flibby05 2005-01-22 21:02:26 UTC
*** Issue 36629 has been marked as a duplicate of this issue. ***
Comment 2 flibby05 2005-01-22 21:03:25 UTC
please have a look at issue 36639 for a second example
Comment 3 flibby05 2005-01-22 21:05:26 UTC
changing summary from "Misleading message when not able to save documents to nfs
server" to "Resaving files on partitions not mounted with parameter"exec"
impossible"
Comment 4 flibby05 2005-01-22 21:06:29 UTC
don't know if this is OOo fault, but still setting to NEW.
Comment 5 thorsten.martens 2005-02-01 12:35:46 UTC
TM->requirements: More a wish for a change, for an enhancement than a defect.
Please have a look.
Comment 6 flibby05 2005-02-08 08:53:24 UTC
enhancement -> defect,
because - based on following user list discussion de.openoffice.org - users do
face this problem and report, that other applications apart from OOo work
flawlessly on this partitions setup. OOo should do the same, thus avoiding user
confusion.
Comment 7 lohmaier 2005-02-08 20:08:56 UTC
maxweber: don't forget to reassign to the default owner when changing the type
from RFE to Defect.

I could not reproduce with Mandrake 9.0 based system. I suspect this to be a
SuSE-only problem.
(this was reported to be broken with local (vfat) filesystems on the german-lang
mailing list as well)
I could not test with a remote filesystem.

Summary: 
If the mount-option "noexec" (implied by the option user(s)) is given on a
SuSE-Linux, OOo cannot save files to the mounted filesystem.
When the same filesystem is mounted with "exec", OOo can save to the filesystem.

This was not reproducible with a Mandrake based distro, but was reported by
several users on the german-lang mailing list (users@de.openoffice.org) (all
using SuSE linux)
Comment 8 lohmaier 2005-02-09 21:54:00 UTC
This issue is invalid since it is caused by a bug in the linux kernel.

Thanks to Stephan Bergmann for his posting to the de-users mailing-list!

More information:
http://www.ussg.iu.edu/hypermail/linux/kernel/0410.0/0478.html

OOo 2.0 will not be affected by this bug since it is build with a newer version
of gcc.
Comment 9 lohmaier 2005-02-09 21:55:28 UTC
closing issue. Nothing for OOo to do...
Comment 10 Stephan Bergmann 2005-02-10 11:35:48 UTC
This should indeed not be a problem for OOo 2.0, but we can still fix OOo 1.1.5
(to work around the Linux Kernel bug).
Comment 11 Stephan Bergmann 2005-02-10 11:36:39 UTC
.
Comment 12 Stephan Bergmann 2005-02-10 11:38:10 UTC
.
Comment 13 Stephan Bergmann 2005-02-14 10:50:59 UTC
fixed
Comment 14 Stephan Bergmann 2005-02-17 11:15:45 UTC
How to test:
- Use a SuSE 9.2 Linux machine.
- Make sure you have some file system mounted noexec.  For example, as su, do
  # mkdir /test
  # mount -t nfs -o noexec v20z-so3:/export/home /test
to mount such an fsys under /test.
- Create a document on that fsys.  Then reopen the document, modify it, save it:
 Instead of error box "Could not create backup copy" it should work now.
- Don't forget to clean up, as su:
  # umount /test
  # rmdir /test
- This issue is Linux-specific, but test other platforms for regressions, too.
re-open issue and try to reassign to tm@openoffice.org
Comment 15 Stephan Bergmann 2005-02-17 11:15:50 UTC
try to reassign to tm@openoffice.org
Comment 16 Stephan Bergmann 2005-02-17 11:15:56 UTC
try to reset resolution to FIXED
Comment 17 thorsten.martens 2005-03-07 14:19:49 UTC
Checked and verified in cws sb30 -> OK !
Comment 18 flibby05 2005-03-10 17:31:29 UTC
*** Issue 43707 has been marked as a duplicate of this issue. ***
Comment 19 flibby05 2005-03-16 08:44:43 UTC
*** Issue 45121 has been marked as a duplicate of this issue. ***
Comment 20 thorsten.martens 2005-07-29 10:42:04 UTC
closed !
Comment 21 Unknown 2010-11-10 21:35:10 UTC
Created attachment 73696