Issue 48316 - Flash object: error activating object. General OLE error
Summary: Flash object: error activating object. General OLE error
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: 680m95
Hardware: All Windows XP
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2005-04-28 04:53 UTC by omvsj
Modified: 2017-05-20 10:55 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

MS PowerPoint. 1 slide with 1 Flash OLE (288.00 KB, application/
2005-04-28 04:56 UTC, omvsj
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description omvsj 2005-04-28 04:53:49 UTC
1. I recieved a Microsoft PPS file with and Flash Embedding object.
2. Impress 1.9.95 opens the document.
3. I run the presentation and the flash object don't start.
4. If I try to "edit" the object via "activating" it (double-clicking on it), I 
get the error "error activating object. General OLE error"

5. I open the same document in Microsoft PP and it runs correctly.
6. Copy the object
7. Swith to OOo Impress
8. Paste (Paste special - Shokwave Flash Object doesn't work. Sometimes crash).
9. Same efect: flash object don't start and same error if trying to edit it.
Comment 1 omvsj 2005-04-28 04:56:53 UTC
Created attachment 25580 [details]
MS PowerPoint. 1 slide with 1 Flash OLE
Comment 2 wolframgarten 2005-04-28 08:11:36 UTC
Comment 3 wolframgarten 2005-04-28 08:11:55 UTC
Comment 4 mobiforest 2006-05-19 20:59:22 UTC
I get the same error when I double-click a PDF file embedded in a word doc,
using oowriter 2.0.2.
Comment 5 oopla 2007-09-27 21:00:12 UTC
I get same error on several OOoWriter docs, on Linux. Docs were created with
1.1.5, now reopening them and trying to edit the embedded Calc tables,
dbl-clicking on them, I get such error.
2.3.0 issues such warning on loading the docs, then the embedded tables look
like images (that's what the small context pop-up toolbar says).
In some case tables where C&C from Calc docs, in others from other tables
embedded in other Writer docs.
Docs format is .doc, since they should be exchanged with MS-O users.

Looks like OLE code is subtly+badly broken, tons of work risk to end in the
trash can :(.
Is there any recovery/repair tool, to at least extract & save such OLE objects?
Comment 6 Marcus 2017-05-20 10:55:51 UTC
Reset assigne to the default "".