Issue 51076 - WW8: Drawing Callouts in groups appear in the wrong place
Summary: WW8: Drawing Callouts in groups appear in the wrong place
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.0 Beta
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2005-06-21 22:32 UTC by navvy
Modified: 2017-05-20 11:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Sample maps with callouts (224.00 KB, application/msword)
2005-06-22 22:52 UTC, navvy
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description navvy 2005-06-21 22:32:39 UTC
I use callouts in Microsoft Word to put labels on maps, using the arrowhead to 
point to the location.  The map is a GIF image saved from multimap.

Grouping the callouts and the map together works within Word, but when I open 
the document in Open Office I find the callouts and arrows have moved, and are 
now pointing to the wrong locations!

I tried ungrouping in Writer, and moving one of the callouts, but it didn't 
seem possible to move individual parts of the callout.  I tried to pick up the 
arrowhead and move it to the correct location, but the whole callout jumped to 
a completely different location.

Problem may be that the Writer callout is created as diagonal corners of a box 
with a line somewhere near it, while the Word callout is created as a line 
with a box attached at the second point of the line.  The most important 
anchor point of the callout should be the first point of the line (ie the 
Comment 1 michael.ruess 2005-06-22 10:09:27 UTC
please attach the offending document (the shorter the better) to this issue, so
that we can reproduce and fix the problem here. You can also send the document
directly ( for the case it contains confidential data. Feel
free to re-open the issue when you've done.
Thanks for supporting us!
Comment 2 navvy 2005-06-22 22:52:13 UTC
Created attachment 27428 [details]
Sample maps with callouts
Comment 3 navvy 2005-06-22 23:03:08 UTC
I've just attached a sample file with two maps.  It's about 224KB.  The first 
map (Brookwood) has the callouts appearing in the wrong place when opened with 
Open Office Writer 1.9.109 but should appear correctly in Microsoft Word 
2003.  The callout for the Pub should point to the railway station (red blob 
on the black railway line).  All three callouts get moved, and the map seems 
to have moved up too.

The second map (Foxham) works OK.  There is only one callout, and it points to 
a building marked P on the map.
Comment 4 michael.ruess 2005-06-23 10:18:59 UTC
MRU->OD: the positions of the Callouts inside the groups are slightly wrong.
Comment 5 navvy 2005-06-23 11:09:33 UTC
My bug report was about inaccuracies in the conversion from a Word document.  
Obvioiusly there needs to be compatibility here, regardless of whether the 
original error is casued by Microsoft or Open Office.

However, the simple solution would have been for me to move the callouts to 
the correct locations using Open Office.  I found this impossible.  I couldn't 
create new callouts as easily in Open Office Writer as in Microsoft Word.

In Word I can choose a callout style, click at location A and drag to location 
B.  I get an arrowhead at A and a box at B.  I can then resize the box and it 
remains linked to the arrow.  Open Office doesn't work this way - A and B 
become the diagonals of a box, and an arrow appears nearby but not joined on.  
The arrow seems to have no relationship to the location that I was pointing 
to.  The box also does not seem to work as a text box - text spills out of it 
and does not word wrap inside it.  Text, box and line appear to be unrelated - 
not really a callout object.

Maybe I've misunderstood how to use it?  Is there an alternative way to put 
arrowed labels on maps?
Comment 6 Marcus 2017-05-20 11:24:43 UTC
Reset assigne to the default "".
Comment 7 Marcus 2017-05-20 11:25:46 UTC
Reset assigne to the default "".