Issue 52264 - interaction 'run program' is defect
Summary: interaction 'run program' is defect
Alias: None
Product: Impress
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0 Beta
Hardware: PC Linux, all
: P2 Trivial with 8 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2005-07-21 12:24 UTC by blind
Modified: 2017-05-20 11:08 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description blind 2005-07-21 12:24:10 UTC
Assigning the interaction 'run program' to an object is defect.

1. insert object
2. assign interaction: 'run a program'
3. point to a (bash-)script
4. clicking object _should_ start interaction, meaning: execute script
standard web browser is opened displaying the script as text file

Because this method is often used to start displaying movies in a presentation
with an external program and it is a basic functionality, I raised the prority.

Comment 1 wolframgarten 2005-07-21 12:33:10 UTC
Comment 2 christian.guenther 2005-07-21 13:45:00 UTC
Set to new and change the target.
Comment 3 christian.guenther 2005-07-21 13:46:59 UTC
I can reproduce te bug.
The bahaviour of the browser depends on the settings of the browser.
Please have a look.
Comment 4 ronnystandtke 2006-05-14 08:24:02 UTC
I just wanted to let you know that I still have this problem with OOo-2.0.2.
Comment 5 mborland 2006-07-07 16:45:26 UTC
This is a serious problem for me.  I used this feature frequently in OO1.X.  It
seems that it should be very, very easy to fix it.
Comment 6 ulutte 2006-10-02 17:05:01 UTC
This is the only convenient way to launch a video under linux. When you are
under KDE, it is "konqueror" that is launched which popups a stupid
confirmation dialog preventing to use it in a live presentation.

Please do something to revert to the 1.4 series behavior.

Comment 7 cybso 2008-05-06 18:51:18 UTC
I can't believe that this bug is still not fixed in 2.4.0...
Comment 8 clippka 2008-05-13 09:42:14 UTC
Comment 9 ulutte 2008-06-13 15:49:47 UTC
This bug is indeed still not fixed in 2.4.0 but its behavior is degenerating
with time. Now it is impossible to launch a program. When using strace to debug,
it seems that when you try to launch a program, say "/home/me/my_program" the
interaction function invocation becomes "/home/me/file:///home/me/my_program"
which yields obviously an error. Seems that this has been implemented without

This feature is still critical to launch a video since with the default function
it is still impossible to finely tune the video behavior like playing the video
when clicking on it or doing auto-repeat.
Comment 10 clippka 2009-02-03 15:00:49 UTC
3.1 contains a new feature to start/pause/stop movies as part of the custom
animation sequence
Comment 11 clippka 2009-02-09 11:05:20 UTC
I understand the demand to create presentations that execute programs.

The question is, how to implement it that it does not have a security impact on
other users.
Nobody wants to open a 'funny' presentation with a screen sized image that
executes "c:\windows\format c:\" without a warning.

But a warning all the time would prevent the ability to script background

cl->fl: do you have an opinion on this?
Comment 12 frank.loehmann 2009-02-09 12:58:15 UTC
FL->CL: OOo provides security settings for macros. (see Security). Is it possible to use
those security settings for actions in Impress also? I guess we would need a new
message box in Impress launched everytime an action tries to start something
outside of Impress. What do you think?

Comment 13 mborland 2009-02-09 13:08:06 UTC
Using the macro security settings or a dialog each time the document is opened
is a very workable approach.
Comment 14 clippka 2009-09-08 18:08:04 UTC
I investigated a little more into this issue to find out what other options I
have than using SID_OPENDOC. I tried osl_executeProcess which at least under
windows didn't start any applications either. I asked hro and he said the better
way to go would be to use the service SystemShellExecute.

Then I found out that SID_OPENDOC implementation in sfx2 already uses this
service. And it executes scripts and executables under windows but not under
linux. This is both inconsistent and a security issue of some sort but it seems
to be a more general issue and not only impress related.

cl->mba: I think the framework team is better suited to handle this one, please
dispatch at your leisure...
Comment 15 Marcus 2017-05-20 11:08:39 UTC
Reset assigne to the default "".