Issue 54029 - Spell checker does work/not work depending on used fonts (Linux)
Summary: Spell checker does work/not work depending on used fonts (Linux)
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2005-08-31 13:27 UTC by rainman01
Modified: 2013-02-24 20:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Screenshot of writer spell check issue (45.06 KB, image/png)
2005-08-31 13:28 UTC, rainman01
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rainman01 2005-08-31 13:27:05 UTC
Problem appears:
- Only in module Writer
- Only with Linux/i386 (I use Debian sarge), not in Windows Version!

Problem description:

1) The spell checker *does* work with some Linux fonts e.g.:
"Bitstream Vera Sans" or "Ikarus" or "Courier 10 Pitch",...
Maybe it works with all TrueType Fonts?

2) But the spell checker does *not* work with some other fonts like:
"Times" or "Helvetica" or "Urw Bookman L"
Maybe this happens only with the standard X11 Fonts?

- Concerns both: automatic background spell checker AND the normal!
- Regardless if the font was changed directly or the default font settings are
changed in Options -> Writer -> Default fonts
- Regardless of what language used

Screenshot: (temporary extern link to my homepage)
Comment 1 rainman01 2005-08-31 13:28:02 UTC
Created attachment 29199 [details]
Screenshot of writer spell check issue
Comment 2 mecrider 2005-09-09 20:27:32 UTC
Is this a duplicate of Issue 53168 or Issue 48472?
Comment 3 rainman01 2005-09-09 21:41:38 UTC
I don't think it's the same as issue 53168, describing that some linux fonts are
incorrectly flagged as "symbol fonts".

I tested it again on 2 Debian Linux Systems (Debian sarge/stable and the current
Debian testing) and the issue ONLY appears in component Writer. Whereas in the
other components Calc, Draw or Impres the spell checker WORKED with the same
fonts, so I don't think the fonts are incorrectly flagged.

And in contrast to issue 53168, at my system this issue appears with standard
Linux adobe fonts like "Times" or "Helvetica".

But maybe it's related to Issue 48472...
Comment 4 rainman01 2005-09-09 22:08:53 UTC
I again tested at Issue 48472 (which is not really good described in details):

At my system this issue is not like described in Issue 48472 that "spell-check
works only with fonts installed in Printer Administration".

In my "Printer Administration (spadmin)" there are only installed "Bitstream
Vera*" and "Lucida*", but spell checker also works with many other fonts
installed on my KDE Desktop.
It seems that with all the truetype fonts in "/usr/share/fonts/truetype" the
spell checker works...

Maybe the issue only concerns adobe fonts, because "Times" and "Helvetica" are
adobe fonts and on my Linux System I can NOT find them neither
"/usr/share/fonts/truetype" nor in "/usr/share/fonts/afms/adobe"...?

Comment 5 rainman01 2005-10-14 22:32:21 UTC
Issue still exists with Version OOO 2.0 rc1 on Linux (Debian stable and testing)...
Comment 6 rainman01 2005-10-29 14:15:25 UTC
Issue is solved now!

I'm very glad to tell you, that since I finally upgraded from RC1 to the final
version 2.0, the issue does NOT exist any more on my two linux systems (Debian
stable and testing)!
(Spell checker now works with the adobe fonts like Helvetica or Times...)

Thanks to anyone working for the OpenOffice team, you're all doing a good job!

With kind regards,
Comment 7 rainman01 2005-10-30 14:02:31 UTC
Sorry, it was my *MISTAKE*   -->  the issue STILL EXISTS in the final 2.0
version !!!

I did oversee, that I have changed my "View" to "Web-Layout" instead of
"Print-Layout", and so in this view it worked properly!

ONLY in Writer (Linux version) AND if I'm in "Print-Layout", the spell-checker
still does NOT using Adobe fonts like "Times" or "Helvetica" like described above...
Comment 8 rainman01 2005-12-29 10:42:07 UTC
ISSUE SOLVED in Version 2.0.1 !!!!
In the latest version this issue does not appear anymore!

Many thanks to all involved developers and the whole OpenOffice team!