Issue 54720 - Incorrect display on a long document in Khmer script
Summary: Incorrect display on a long document in Khmer script
Status: CLOSED DUPLICATE of issue 17171
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: 680m128
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
Keywords: oooqa
Depends on:
Reported: 2005-09-17 09:24 UTC by lists
Modified: 2005-09-18 03:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description lists 2005-09-17 09:24:34 UTC
In a long document written in Khmer script, when text is added to it, it starts
displaying incorrectly. It does not matter if the text added is English or
Khmer. Last tested on m128. It is unclear if the problem is related to the
script or to the length of the text or another problem, but only a Khmer script
file is available for testing. Generally Khmer is displayed correctly in both
text and user interface, in both Linux and Windows.

The problem is easy to reproduce on Windows, but correct display of Khmer
requires some configuration on the computer.

1) Fonts

Khmer fonts can be downloaded from
This particular document requires "Khmer OS", "Khmer OS Moul" and "Khmer OS System"

2) Correct version of usp10.dll file (1.465 or later). This is Microsoft's
Uniscribe Engine, for handling of Complex scripts, and it must be placed either
in the applications folder or in the c:\windows\system32 directory. The file
provided with Windows XP (version 1.409) does not support Khmer, but the one
provided by MS Office 2003 does (in Program Files\Common Files\Microsoft
shared\OFFICE11. If such file is not available, please contact the issue reporter.

To reproduce the issue: open the document, go to the end and, without starting a
new line, start typing:

123 123 123 123 123 123 123

when you have typed 5 or 6 times 123<space>, some of the 123 blocks will
dissapear. Other behaviours that we have detected include not being able to type
any more in a document (in another version of the same document, new characters
are ignored) or dissapearance of characters in the document (Khmer characters
dissapear, only the parenthesis stay in place).

This could be a problem with the file itself. We have tried saving to MS XML
format and back, and copying the contents to a fresh document.. but the problem
remains, it somehow seem to be related to the contents itself.

The file that has the problem (as detected on Windows) is in:

while the file that does not allow entering more characters on Linux is in:
Comment 1 lohmaier 2005-09-17 21:22:42 UTC
duplicate. Not a problem with khmer, but with the length of one single paragraph.
A paragraph cannot contain more than 65534 characters.

If you really can reproduce with the attached windows-document by simply typing
"123" a couple of times, then please reopen. There the limit is not yet reached....

*** This issue has been marked as a duplicate of 17171 ***
Comment 2 lohmaier 2005-09-17 21:23:37 UTC
closing issue. Reopen (and set OS to windows) when you really can reproduce with
the attached windows-document.
Comment 3 lists 2005-09-18 03:31:29 UTC

Yes, this seems to be the problem. There were 11 and half pages without a
paragraph break. There is not 65.000 character, at most about half of them, but
these are 2-byte unicode characters, which use 65.000 bytes, so I assume it is
the same problem.

I tested breaking the paragraph and it worked correctly.