Issue 55050 - DDE links set to Manual update don't work with non-OpenOffice apps
Summary: DDE links set to Manual update don't work with non-OpenOffice apps
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: 680m130
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo
Depends on:
Reported: 2005-09-25 03:25 UTC by andreasro
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Text document with manual DDE field (5.78 KB, application/vnd.oasis.opendocument.text)
2005-09-27 09:41 UTC, andreasro
no flags Details
Screenshot of the Fields dialog showing how the field is created (31.40 KB, image/jpeg)
2005-09-27 09:44 UTC, andreasro
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description andreasro 2005-09-25 03:25:19 UTC
Insert a DDE link, for example to MS Excel, through Insert | Fields | Other...
I'm just using Excel as an example. The problem seems to happen with other DDE
servers as well.

If the link is set to DDE manual, the field value is blank. It stays blank
regardless of whether you perform an update. I have confirmed that Writer sends
a request to the DDE server, but the text returned by the server is never displayed.

If you insert the same link, but set it to DDE automatic, the value is shown

If you insert a link to OpenOffice Calc, both DDE manual and DDE automatic show
the field value correctly.
Comment 1 michael.ruess 2005-09-26 16:56:25 UTC
Reassigned to ES.
Comment 2 eric.savary 2005-09-27 08:54:30 UTC
How do you insert the DDE Link (Please give the complete DDE statement)?
How do you set the Manual flag?
Please attach a sample document.
Which version of OOo are you using ("current" is not a suiting flag)
Comment 3 andreasro 2005-09-27 09:40:31 UTC
I'm inserting the DDE Link through the following menu items (from the top-level
menu: Insert > Fields > Other...

I select "DDE field" from the "Variables" tab
The "DDE Manual" option is selected by default under "Format".
I enter a name eg Excel, and the DDE statement: Excel [Book1]Sheet1 R1C1
I hit the "Insert" button

The results is a blank field value.

If I follow the same procedure, but select "DDE automatic", the field value
shows up ok.

I have tried this under versions 1.1.3, 1.1.5 and 1.9.125 all with the same result.

Comment 4 andreasro 2005-09-27 09:41:46 UTC
Created attachment 29923 [details]
Text document with manual DDE field
Comment 5 andreasro 2005-09-27 09:44:29 UTC
Created attachment 29924 [details]
Screenshot of the Fields dialog showing how the field is created
Comment 6 eric.savary 2005-09-27 15:08:14 UTC
ES->PB: AFAIK, DDE links can only be updated automatically. Then, "Manual"
should be disabled in the dialog when the considered link is a DDE link.
The problem is that the dialog can't differenciate between all the kinds of
links. WONTFIX? 
Comment 7 ace_dent 2008-05-15 14:27:14 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please re-test with one of the latest versions of OOo -
the problem(s) may have already been addressed. Either use the recent stable
or consider trying the new OOo 3 BETA (still in testing):
Please report back the outcome so this Issue may be closed or progressed as
necessary - otherwise it may be Resolved as Invalid in the future. You may also
wish to search for (and note) any duplicates of this Issue that may have
advanced further :
Cleaning-up and Closing old Issues as part of:
~ The Grand Bug Squash, pre v3 ~