Issue 70435 - Add new local linux installation instructions to
Summary: Add new local linux installation instructions to http://download.openoffice.o...
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Documentation (show other issues)
Version: current
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2006-10-15 00:03 UTC by towsonu2003
Modified: 2013-08-05 14:15 UTC (History)
1 user (show)

See Also:
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description towsonu2003 2006-10-15 00:03:05 UTC
I have found these instructions incredibly helpful for doing an installation of
openoffice. the advantage of using these include:
1. don't touch your existing OOo installation
2. related to above, don't touch your distro's settings
3. don't be dependent on your distro's packaging of new OOo releases
4. install quick and easily without the fear of "borking the system"
5. in debian, do not deal with rpm packages
6. in rpm-based distributions, don't have to upgrade from the distro-distributed
package to openoffice-distributed package (hence no playing around with
distro-speficic settings)


The link to the instructions is:

Instructions (copy paste):
Some people miss the old installer which allows non-root, per-user installation.
This type of installation is nice if you don't have root privileges or if you
want to have multiple versions of installed concurrently. Well,
the same is possible with the .RPM installer.

Also, you can vary this procedure to install system-wide on a
non-RPM system using root privileges.


   1. Skill: command-line use
   2. Program: rpm2cpio
   3. Program: cpio
   4. File: OOo_2.0.0_LinuxIntel_install.tar.gz (contains .RPMs)

Where do you get rpm2cpio if you do not use an RPM system? Your distribution may
carry it, and look for the rpm package. For example, Debian and Slackware does
both carry rpm2cpio in their respective rpm packages.

Procedure: installing locally as non-root

   1. Download OOo_2.0.0_LinuxIntel_install.tar.gz to ~
   2. Start a shell (also called a terminal)
   3. mkdir ~/ooo; cd ~/ooo
   4. tar xvzf ../OOo_2.0.0_LinuxIntel_install.tar.gz
   5. for i in `ls OOO680_m3_native_packed-2_en-US.8968/RPMS/*rpm`; do rpm2cpio
$i | cpio -ivd; done
   6. (optional) rm -rf OOO680_m3_native_packed-2_en-US.8968
   7. (optional) rm ~/OOo_2.0.0_LinuxIntel_install.tar.gz

Procedure: running locally as non-root


Procedure: associating with file types as non-root

This depends on your system, but if you use Nautilus, try this:

1. In Nautilus, browse to the file you want to open.
2. Select the file.
3. Click File->Open with other application.
4. Specify ~/ooo/opt/openoffice.org2.0/program/soffice as the program.

Procedure: installing system-wide as root #1

Your Linux distribution may have an updated 2.0.0 package
available. If It's not in your standard repository, it may be in a testing
repository or available through a users' website.

Procedure: installing system-wide as root #2

To convert from .RPM to your native package format, try alien or rpm2tgz.

Procedure: installing system-wide as root #3

To install system-wide on non-RPM system, simply follow the local installation
procedure and move ~/ooo/opt to /opt. Also, (using rpm2cpio) install the
appropriate system integration package from
Comment 1 grsingleton 2006-10-15 14:12:10 UTC
First things first: You have identified a page that is not under the control of
either the doc project or the on-line help team. 
Second, most of your suggestions are covered by the Setup Guide ( ) which
you should review.
Third, try component Installation
Comment 2 aziem 2006-10-15 18:38:30 UTC
>First things first: You have identified a page that is not under the control of
>either the doc project or the on-line help team. 

As the author of that article, I offer them permission to use, modify, and
distribute it.
Comment 3 towsonu2003 2006-10-15 19:34:33 UTC
> most of your suggestions are covered by the Setup Guide

this type of installation is deeply buried in the documentation (where I still
can't find it, even with the link you provided)), and absent from (an online
documentation file) where most people will look for it. is what you see
first off when you're downloading OOo. 

this bug: documents my
claim, as the reporter says and I quote:
Where are the install files?  RPMs are useless to me.  I have Linux systems that
are 5 and even 10 years old that have been continuously updated.  No way any RPM
system will ever grok such bastard children.  The OO 1.0 install worked just
fine, I need the same thing for OO 2.0
---------quote ends-----

apart from requesting a new feature, what he is saying is that he couldn't
*find* the instructions I posted (the forum link). 
Comment 4 Uwe Fischer 2006-10-16 13:51:50 UTC
set to owner of www component
Comment 5 Uwe Fischer 2007-08-06 10:07:08 UTC
should be submitted to the "www" component. Tried three times but cannot change
component. Process seems to be broken.
Can someone please submit this issue new to the correct component?

I would suggest to include a link to to the download web page
Comment 6 Uwe Fischer 2007-08-06 12:52:25 UTC
changing owner
Comment 7 frank.thomas.peters 2008-04-30 15:52:24 UTC
Comment 8 stx123 2011-03-23 16:13:42 UTC
Reset QA Contact to new default
Comment 9 Marcus 2013-08-05 14:15:46 UTC 2.0.4 is outdated and no longer supported.

Install instructions for Apache OpenOffice on Linux can be found here: