Issue 72480 - OOo crashes when deleting text within a drawing component
Summary: OOo crashes when deleting text within a drawing component
Alias: None
Product: Draw
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.4
Hardware: PC Linux, all
: P2 Trivial (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo, oooqa
Depends on:
Reported: 2006-12-12 05:33 UTC by srix
Modified: 2017-05-20 11:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

The file that causes the crash (7.41 KB, text/plain)
2007-01-26 00:13 UTC, shahid_sorkhabi
no flags Details
error_report as displayed by Oo (15.87 KB, text/plain)
2007-02-01 00:38 UTC, shahid_sorkhabi
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description srix 2006-12-12 05:33:44 UTC
OOo (Drawing, Word Processor, Impress) crashes when editing text within a
drawing.  Steps to reproduce:

1. Open a document (text, drawing, presentation)
2. Select a drawing type (e.g. rectangle) and draw the figure in the document
3. Double click inside the drawing, type at least 2 lines of text with a CR in
4. Backspace over the last line all the way back to erase the newline
5. OOo crashes

IMPORTANT: This happens ONLY when OOo-gnome and OOo-gtk packages are installed.
I could reproduce this with OOo 2.0.2 on Ubuntu 6.06 and OOo 2.0.4 on Ubuntu
6.10. When the gnome integration package is removed OOo does not crash.
Comment 1 wolframgarten 2007-01-03 12:38:55 UTC
Are the Office version from the official OOo site or are these builds provided
by Ubuntu? Thanks in advance.
Comment 2 wolframgarten 2007-01-05 12:11:36 UTC
Have you been asked to send a crash report and did you do so? Which email or
description did you use so I can find it in the database? Thanks.
Comment 3 wolframgarten 2007-01-09 10:19:41 UTC
closing, no more info arrived. Please fell free to reopen. Thanks .
Comment 4 srix 2007-01-12 03:59:45 UTC
(Sorry, didn't check back here for the last few days).

I've used Ubuntu packages from their official repository. But as far as I
remember, I used the official OOo tar.gz in my earlier system and had the same
problem (when the Gnome/Gtk package is also installed). Also, it doesn't ask to
submit any report - only tries to recover the document. Should I enable
something somewhere to force crash report submission?
Comment 5 srix 2007-01-13 10:46:58 UTC
Update: I just tried with the official 2.1 release from the OOo site, and I
still get the crash.
Comment 6 shahid_sorkhabi 2007-01-26 00:13:22 UTC
Created attachment 42473 [details]
The file that causes the crash
Comment 7 shahid_sorkhabi 2007-01-26 01:00:10 UTC

Attempted to replicate the crash (using 'crashes.odt' ,see attached) on two
different distros with the following results:

Ubuntu 6.10 Edgy Eft OpenOffice v2.0.4 (Linux whitewizard 2.6.17-10-generic #2
SMP i686 GNU/Linux with gnome integration packages _installed_): Crash _CAN'T_
be replicated.

Arch Linux 0.7.2 Gimmick OpenOffice v2.0.4 (Linux M6805 2.6.18-ARCH #1 SMP
PREEMPT i686 Mobile AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
with gnome integration packages _installed_): Crash successfully replicated.

To try to replicated the crash in gnome:
1- Open up OpenOffice Draw
2- Select "File|Open"
3- Select 'crashes.odt'
4- After the document has been loaded double click inside the blue rectangle to
obtain the cursor.
5- Place the cursor at the end of the second line.
6- Press and hold down Backspace
7- When the 2nd line has been fully erased & before the 1st line is reached -->
Oo crashes

Both OpenOffice packages are from their respective distro's official repositories.

Other Considerations:
* Under Arch linux, when Oo crashes it _does_ attempt to send out a report. I
have already sent out one:
"Attempting to replicate bug#:72480
* Both systems have gnome integration packages installed. 
* Arch Linux is a high performance i686 optimized distribution. All packages are
compiled for i686.
* Both systems run Gnome 2.16.1.
Comment 8 shahid_sorkhabi 2007-01-26 01:02:50 UTC

Step 1 - Open up OpenOffice *Writer*

Comment 9 wolframgarten 2007-01-26 09:49:35 UTC
Would it be possible to attach the stackreport of the crashreporter directly to
the issue? I cannot find it in the database when searching for your name or
title. Thanks.
Comment 10 shahid_sorkhabi 2007-02-01 00:38:02 UTC
Created attachment 42618 [details]
error_report as displayed by Oo
Comment 11 shahid_sorkhabi 2007-02-01 00:39:08 UTC
I have submitted the error report above. The file was made in Linux using Gedit.
Comment 12 wolframgarten 2007-02-01 12:34:52 UTC
Reassigned. @cl: Anything visble here from the stack? Thanks.
Comment 13 wolframgarten 2007-03-06 09:40:46 UTC
Set to new.
Comment 14 wolframgarten 2007-03-06 09:41:31 UTC
Set to target later.
Comment 15 clippka 2010-06-01 14:29:08 UTC
cl->wg: not much to see from the stack, only that accessibility seems to be
active. Can you reproduce this with accessibility enabled?
Comment 16 wolframgarten 2010-06-04 11:13:35 UTC
Could not reproduce on Ubuntu 9.1 with DEV300_m75.
Comment 17 Marcus 2017-05-20 11:31:19 UTC
Reset assigne to the default "".