Issue 73032 - Can't create table in Derby database
Summary: Can't create table in Derby database
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.1
Hardware: PC Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2007-01-01 12:11 UTC by greenrd2004
Modified: 2013-08-07 15:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description greenrd2004 2007-01-01 12:11:06 UTC
I created a new Derby database (using Derby version, tried to create a
table in Design View, and it wouldn't save the table - said there was a syntax
error: Encountered "," on line 1, char 40 (i.e. the first comma below).

This was the offending statement, according to the derby.log file:


I am using Sun JDK 1.6.
Comment 1 marc.neumann 2007-01-03 13:35:20 UTC

I can reproduce this.

confirm, set target and reassign to the right developer

Bye Marc
Comment 2 ocke.janssen 2007-08-31 10:11:16 UTC
@msc: Could you please verify, if this still occurs in SRC680m225? I can create
tables here.
Comment 3 drewjensen.inbox 2007-10-15 03:37:14 UTC
Installed Derby under XP as a network server
JRE 1.6.0_03

Using JDBC connection and default settings:

Can create tables, but can not set the PK for the table via the GUI. 
Adding data to tables via SQL window worked as expected.

Further comments added to dba dev mailing list.

Comment 4 thorsten.ziehm 2008-05-23 08:34:08 UTC
Changed target to OOo 3.x Please take a look, if the still exists and what the
correct target should be.