Issue 73036 - Autoinput preferes capitalization instead of choosen lower letters in Calc
Summary: Autoinput preferes capitalization instead of choosen lower letters in Calc
Alias: None
Product: Calc
Classification: Application
Component: ui (show other issues)
Version: OOo 2.1
Hardware: PC Windows 2000
: P3 Trivial with 4 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
: 73366 (view as issue list)
Depends on:
Reported: 2007-01-02 01:24 UTC by kaschig
Modified: 2013-02-07 21:56 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description kaschig 2007-01-02 01:24:46 UTC
I'm sorry to get again a new issue like issue No. 5743. But I'm some kind new
user and encountered the described (below) feature just now.

I'm using OOo 2.1 (german) on Win2000 - so I'm sorry if I don't mention the
'right' (english) menue-spellings ;-)

AutoInput is switched on, AutoCapitalization is switched off.

1) create a new spreadsheet
2) type xxxx in a cell
3) move to the cell below that and try to enter Xxxx
4) move to another field

After leaving the cell I got 'xxxx' in this cell too.

I got the point (solution?!), to switch off AutoInput, but this 'workaround'
seems to be not real comfortable to me. I realize this behaviour on a newly
converted sheet (from excel) with my password lists - real often there are
entries like "kaschig" but even "Kaschig" - to switch the 'AutoInput' each time
is some kind nasty - remember it's a "global" option, effecting all open sheets.

I really suggest to respect explicit choosen upper/lower letters.
Comment 1 kpalagin 2007-01-02 08:05:00 UTC
Confirming with OO 2.1 on WinXP - autoinput suggests string even if 
capitalization is different and, if user confirms by pressing enter, string is 
converted to unintended capitalization. Please see attached screenshot - to 
the left from arrow is what user typed, to the right - what user gets after 
pressing Enter.
Comment 2 Joost Andrae 2007-01-02 12:29:07 UTC
/Tools/Cell Contents/AutoInput is used to provide strings used within the cell
range above to allow easier manual creation of lists. AutoInput is not available
if you enter a string outside a cell range. The behavior is intended by Calc.
Comment 3 kaschig 2007-01-02 21:34:57 UTC
I understand Your intention (or that what You described as AutoInput-feature).
But I cannot follow this.

Problem is on my behalve, that the AutoInput-feature is only switchable on
program-level. It even isn't switchable on column-level.

Example: I have two spreadsheets open (not even an extensive usage, I think),
one with my password-lists (often changes for some reasons...), the other one
with my business-account-statements (with a lot of recurrent lines of bookings).
While I go to the password-column and the login-name-column I have to set
AutoInput to off, changing to other columns in the first sheet, setting it to on
again, changing to the second sheet having it set to on. And additional having
set it to 'on' in the login-name-column is more usefull - because I really often
use names like 'kaschig' or 'Kaschig' e.g. (okay, the login-name is not changing
as often as the password ;-))) ).

Conclusion: the behaviour of the AutoInput-function is not optimal in all cases
and I suggest to change it. Perhaps the problem is more offensive in
not-english-languages (in my case: german) for more often having the first
letter of words/lists-entries possibly BOTH cases (lower AND upper). And believe
me, this makes sense ;-)

Simpliest solutions seems to be: Calc-AutoInput should respect upper/lower-cases
as entered, like it does while doing the input - THIS behaviour lookes great,
like that I expected. The problem is just on leaving the field (if I have
entered a 'whole' word there is NO need to changed it again!)
Comment 4 kpalagin 2007-01-11 12:40:28 UTC
*** Issue 73366 has been marked as a duplicate of this issue. ***
Comment 5 frank 2007-01-18 14:41:28 UTC

tried it with the upcoming 2.2 build m198 and could not reproduce, Xxxx after
xxxx in another cell gives the desired Xxxx entry after confirming with enter.

So it's closed worksforme.

Comment 6 frank 2007-01-18 14:41:58 UTC
closed wfm
Comment 7 kpalagin 2007-01-19 14:19:54 UTC
I have just tried with 680m1 (9107) on WinXP and Calc still lower-cases "Xxxx" 
(after entering "xxxx").
I am reopening the issue.
Comment 8 frank 2007-01-19 15:03:30 UTC
Hi Kyrill,

what you describe is perfectly correct and the opposite of what the original
submitter has done.

The Autocompletion perfectly respects what you're typing. Starting with a lower
case x it will be filled with the three other x's, starting with upper case X it
act's the same way, respecting what you've typed. So this Issue is a worksforme
Issue if not an invalid one.

Comment 9 frank 2007-01-19 15:03:48 UTC
closed wfm
Comment 10 donpaolo 2007-08-09 22:30:29 UTC
The issue is still present in 2.2.1 (debian unstable).

I consider it cannot be closed, because switching on/off the feature is
invisible to the normal user. Nobody could think of looking for such a option in
a 3rd-level submenu!!!

I personally lasted 1 year thinking it was a bug, and not a feature, because I
was looking for something related in the options and couldn't find nothing.

Please open the bug again.
Comment 11 clement_pillias 2009-02-09 22:44:06 UTC 3.01 still has the behavior described by Kaschig, and this should
be corrected.

It is very annoying for the user, so please at least change the "Closed -
worksforme" status of this issue to "enhancement".
Comment 12 kaschig 2009-02-10 00:55:18 UTC
I'm sorry to disagree. I'm using OOo 3.0.1/300m15 (build 9379) even on Win2000
SP4 (german) - it's great, I am able to enter "xxxxx" in row 1, switch with
<enter> to row 2, enter "X" which is completed to "Xxxxx" and "x" in row 3 to
"xxxxx". So it works on me! BTW: Thanks for the good work!

(set Extras/Zellinhalte/AutoEingabe to true - which seems to be the default)

So just keep it closed.
Comment 13 clement_pillias 2009-02-10 12:45:08 UTC
It is curious: when I do what you told, I get "xxxxx" in every cell, with no
capitalization in the second row.

I use the same version (000300m15 build 9379), but under Mac OS X 10.4 PPC and
french localization. Maybe a platform-specific issue? I know that this issue has
the "platform" field set to PC, but what should we do then, open a new issue or
change the platform in this one and reopen it?
Comment 14 kaschig 2009-02-16 22:40:18 UTC
Okay, some more tests results in a curiosity... seems to be 'estimated'
behaviour as desired by programmers for some reason, but I can't get the point...

It works for me with most input. I DOESN'T work for me with some mathematical
subjects: "minus", "plus", "wurzel", "pi", "gleich", "quadrat" (it's a German
language OOo!) - they're always kept in the case they were put the first time
into that column. Regardless of the type of the cell (text, 'standard', date,

May somebody please explain that behaviour?

Other 'words' work (like 'usa' <-> 'Usa' <urks>, 'Hilfe' <-> 'hilfe', 'work' <->
'Work', 'Dadada' <-> 'dadada' in the same column).

Comment 15 frank 2009-02-17 08:28:03 UTC
removed me from CC
Comment 16 Shari 2012-03-19 20:33:47 UTC
(In reply to comment #15)

This is still happening with 3.3.0 Build:9567 Windows 7
This is not an enhancement, this is a bug, and imho critical. That you can't get the spreadsheet to type what you want without turning off "Use replacement table" is critical. I can not return to using OOo until this is fixed. This is been going back and forth since 2002. It works correctly in a version, then it doesn't. I don't understand why it gets fixed and then reverts. I was using LibreOffice and now it's doing it again in there AAAAAHHHH.