Issue 73277 - Referenced Draw file causes lockup
Summary: Referenced Draw file causes lockup
Alias: None
Product: Draw
Classification: Application
Component: editing (show other issues)
Version: OOo 2.1
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo, oooqa
Depends on:
Reported: 2007-01-09 03:57 UTC by skeller49
Modified: 2017-05-20 10:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Any manipulation causes Draw to lockup (7.33 KB, application/x-compressed)
2007-01-09 03:58 UTC, skeller49
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description skeller49 2007-01-09 03:57:13 UTC
The referenced drawing at consistently causes
Draw and Write (if running) to lock up.  Download and open the file.  Do a
Select All.  Note that the selection highlight does not appear.  Then simply
attempt to scroll the page or any other action - on my XP system (running OO
2.1) and a second XP system running 2.0.4, OO is totally seized.  Tried waiting
a few hours and did not recover.

Most any other manipulation of the object will also cause a lockup.  About the
only safe action is to immediately close the file.  Hope this helps.  I can be
reached at 

Comment 1 skeller49 2007-01-09 03:58:36 UTC
Created attachment 42022 [details]
Any manipulation causes Draw to lockup
Comment 2 wolframgarten 2007-01-09 07:57:03 UTC
The problem is reproducible, yes. But it would really help if you could tell us
what we are seeing there. How did you reproduce the file? Are there only these
little green circles or are they 3d objects, is it a group or what? Thanks in
Comment 3 wolframgarten 2007-01-09 08:20:44 UTC
Ok, selecting the "thing" and waiting long enough brings up a "polygon with
65536 points selected" -message....
Comment 4 wolframgarten 2007-01-09 08:33:00 UTC
The file does not lock up the system, it is just a question of RAM and CPU
power. Would it be possible to warn the user or get a progress bar so the user
can see that there is something happening?
Comment 5 skeller49 2007-01-09 19:20:53 UTC
Answers first.  The object was created in Draw, and is an array of 2d ovals
through a sequence of copy paste (did one, copy/paste, align, copy/paste those
two, align to a square, copy/paste... and so forth.  Background color, etc. were
all defaults from my system.

On it not being a lockup.  Perhaps if I waited several hours it would eventually
work itself out - how long did it take on your system and what type is it?
Consider that both systems I tried it on were XP with all updates, 3.4Ghz Pent D
dual processor with 2G ram.  Far from lightweight systems.  Please consider that
system environment could be a factor, or that the problem is intermittent for
return time.
Comment 6 simon_b 2007-02-02 12:03:41 UTC
OS: Windows XP
OO Version: 2.1

I was able to reproduce the problem using these steps:
1. Open the attachment OO_crasherA.odg
2. Scroll-up to view the array of 2d ovals
3. Attempt to move one of the ovals repeatedly

I attempted to move an oval several times.  After a few attempts, OO stopped
Comment 7 clippka 2007-09-12 13:34:10 UTC
Comment 8 Marcus 2017-05-20 10:48:05 UTC
Reset assigne to the default "".