Issue 74546 - 100% cpuload and programm hang for up to 2minutes while working with bullets
Summary: 100% cpuload and programm hang for up to 2minutes while working with bullets
Status: CLOSED DUPLICATE of issue 67772
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.4
Hardware: PC Unix, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
Depends on:
Reported: 2007-02-14 16:00 UTC by dobrowolsk
Modified: 2007-02-15 08:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

File which contains that error (18.52 KB, application/vnd.oasis.opendocument.text)
2007-02-14 16:01 UTC, dobrowolsk
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description dobrowolsk 2007-02-14 16:00:49 UTC

when I worked with this file ,
writer hung for up to 40 seconds when inserting a new line in a passage that
uses bullets. The same happens when pressing tab oder clicking the "->" button.
In this time the cpu-usage (Centrino 1,8 GHz) is at 100% and OpenOffice stops
responding. This time increased while working with the document. Now it even
takes 20 seconds to open. At the beginning the hangtime was not noticable and
increased then fast from 2 seconds up to 40. I am sure it increases even more.

The same happens with OpenOffice 2.1 on Unix/X11 and OpenOffice 2.1 on Windows XP.
It doesn't happen at my friend who uses openoffice 2.0.2 on Windows XP

To reproduce the error, simply insert a new line e.g. after "Welche Funktionen
soll die Personalplanung bieten?".

I copy-pasted the whole content of the file using Crtl-A Crtl-C Crtl-V into a
blank file and got the same error.

That document was created using MS Word 2007 and later converted to odt with

I hope anyone finds that strange error.

Ralf Ebert
Comment 1 dobrowolsk 2007-02-14 16:01:31 UTC
Created attachment 43019 [details]
File which contains that error
Comment 2 kpalagin 2007-02-15 07:18:21 UTC
Confirming with 2.2 m7 on WinXP - adding line after "soll die Personalplanung 
bieten" causes soffice.bin to use 100% CPU on P4 2.4GHz for about 40 seconds.

(Seems to deserve P2 and 2.2 target, but lets leave this to developers).
Comment 3 michael.ruess 2007-02-15 08:07:29 UTC
Same problem as issue 67772.
As a workaround, you shoulöd turn off "consecutive numbering" for each list in

*** This issue has been marked as a duplicate of 67772 ***
Comment 4 michael.ruess 2007-02-15 08:11:48 UTC
Closing duplicate.
Comment 5 kpalagin 2007-02-15 08:25:41 UTC
I suggest voting for 67772