Issue 82652 - Writing protection passed when drag-n-droping text inside a protected frame
Summary: Writing protection passed when drag-n-droping text inside a protected frame
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.3
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2007-10-16 11:09 UTC by oukourj
Modified: 2017-05-20 11:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description oukourj 2007-10-16 11:09:41 UTC
I tried to post with the newbie's form but it told me "The person's name is
-idontknowwhat, you can't post". Or something like that =)
So informations like "Subcomponent" may be wrong. But the description is good
though, please take note of it!!
Thank you.

Description of Problem:

You still can copy text inside a writing protected frame by dragging and
dropping a selected text in it.
(//I'm using OOo 2.3.0, your form doesn't list it though!)

Steps to reproduce the problem:
1. Create a frame
2. Protect it from editing it's content in the "Options" panel. Accept.
3. Write some chars outside the frame, select them, drag them and drop them
inside the frame.

Actual Results:

Chars are written.

Expected Results:

Chars shouldn't be written as they are written in a writing-protected zone!

How often does this happen?

Every time I test it :)
I tried various Frames configurations, like "protect from everything/don't";
"test just after creation/don't"; "show a border/don't"... So I think it's just
not been thinked about when coding... right? Whatever, thank you!

First I was on OOo 2.2.3; I upgraded it before posting here, but it's exactly
the same with OOo 2.3.

Additional Information (OS patch level, drivers, library
version, etc.)
Windows XP v5.1
Dell Dimension C521
Thank you
Comment 1 michael.ruess 2007-10-16 12:34:43 UTC
MRU->OS: it is possible to place text via drag and drop into a write-protected
Comment 2 Daniel Benkmann 2010-04-19 10:11:38 UTC
This issue still exists with OOo 3.2.

The problem also isn't just restricted to drag&drop. On Linux you can also paste
text into a protected frame by using the middle mouse button paste
functionality. My guess is the underlying problem is the same.
Comment 3 Marcus 2017-05-20 11:22:06 UTC
Reset assigne to the default "".