Issue 83692 - Add interface for OnLoadFinished event
Summary: Add interface for OnLoadFinished event
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: joerg.skottke
QA Contact: issues@framework
Depends on:
Reported: 2007-11-16 10:12 UTC by drewjensen.inbox
Modified: 2009-10-09 08:11 UTC (History)
2 users (show)

See Also:
Latest Confirmation in: ---
Developer Difficulty: ---

test case (19.41 KB, text/plain)
2009-09-10 10:02 UTC, Mathias_Bauer
no flags Details
test case (19.41 KB, application/vnd.oasis.opendocument.text)
2009-09-10 10:02 UTC, Mathias_Bauer
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drewjensen.inbox 2007-11-16 10:12:21 UTC
Currently the OnLoadFinished event is only available via the API, it should be
available from the tools > customize > events UI also.
Comment 1 maison.godard 2007-11-16 10:20:13 UTC
changing target & component
Comment 2 Mathias_Bauer 2007-11-19 15:45:02 UTC
We must provide new UI strings for some of the events that currently aren't
visible in the event configuration dialog.
Comment 3 maison.godard 2007-11-19 16:04:05 UTC
what about creating an alias for OnLoadFinished as this name is not good because
occuring before OnLoad

just a new name that redirects internally to OnLoadFinished : BeforeOnLoad 
Then, just advertize this new name BeforeOnLoad (as OnLoadFinished is even not
in devGuide)
Comment 4 Mathias_Bauer 2008-05-19 09:25:46 UTC
too late for new strings  -> 3.1
Comment 5 Mathias_Bauer 2008-11-05 13:24:23 UTC
Taking over
Comment 6 Mathias_Bauer 2009-05-11 09:41:26 UTC
It has been a while since this issue has been reported. ;-)

Anyway, I want to get if fixed. I think the problem isn't the name of the new
event, the problem is "OnLoad" that better should be "OnOpen". So if we are
talking about an "alias" (I think we have to keep the old one for
compatibility), we should introduce "OnOpen" as a replacement for "OnLoad" and
keep "OnLoadFinished". This reflects pretty well that "OnOpen" if sent only for
documents being "opened" (means: shown to the user), not just "loadede" (means:
brought into memory).

I will start discussion about this on
Comment 7 Mathias_Bauer 2009-06-03 15:09:44 UTC
After discussing it on dev@api I think that replacing "OnLoad" by "OnOpen" (but
keeping the old name for compatibility reasons in deprecated state) is the best
way to go.
Comment 8 drewjensen.inbox 2009-06-03 15:15:29 UTC
Yes - I did follow the discussion (every time I had something to add there someone 
beat me to it..) and it seems this is the right decision. 
Comment 9 Mathias_Bauer 2009-06-04 22:07:12 UTC
I added a bunch of other events that also existed internally already. Don't get
irritated about how full the listbox now is. :-)

Here are the "new" events:


and for Writer


There are some more events where I'm in doubt whether it makes sense to give
access to them for bound macros (they are supported by the EventBroadcaster though):


and for Writer

Comment 10 Mathias_Bauer 2009-06-04 22:39:02 UTC
I forgot one: "OnTitleChanged"
Comment 11 Mathias_Bauer 2009-07-29 10:35:51 UTC
I postpone the interface name change to a further CWS and just added the "new"
Comment 12 Mathias_Bauer 2009-09-01 11:43:23 UTC
@jsk: please verify
Comment 13 joerg.skottke 2009-09-08 08:46:57 UTC
Quite a number of autotests might possibly be affected here
- anything touching the tools/customize diealog
- anything touching eventbindings

Adding a few tests to the list of required autotests.
Comment 14 Mathias_Bauer 2009-09-10 09:59:08 UTC
I attached a test document to test the possible assignments.
The event "LoadFinished" as well as some others (explained in the test document)
can only be bound to global macros, not to document macros.
Comment 15 Mathias_Bauer 2009-09-10 10:02:28 UTC
Created attachment 64667 [details]
test case
Comment 16 Mathias_Bauer 2009-09-10 10:02:29 UTC
Created attachment 64668 [details]
test case
Comment 17 joerg.skottke 2009-09-11 14:07:02 UTC
svn commit -m "#i83692# - Mandatory automated test case plus test document"
Sende          framework/optional/f_basic_documents.bas
Hinzufügen     framework/optional/includes/
Hinzuf. (bin)  framework/optional/input/BasicDocs/BasicEvents.odt
Sende          global/system/includes/
Sende          global/system/includes/
Sende          global/tools/includes/required/
Sende          global/tools/includes/required/
Ãœbertrage Daten .......
Revision 276066 übertragen.
Comment 18 joerg.skottke 2009-10-09 08:11:36 UTC