Issue 85198 - Maimerge Wizard does not accept CSV address data source with space in name
Summary: Maimerge Wizard does not accept CSV address data source with space in name
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.3
Hardware: All Windows, all
: P3 Normal (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2008-01-13 07:53 UTC by jmichae3
Modified: 2014-03-13 16:19 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.1.0-beta
Developer Difficulty: ---

Test Kit (1.08 KB, application/x-zip-compressed)
2014-03-13 16:13 UTC, Rainer Bielefeld
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jmichae3 2008-01-13 07:53:22 UTC
in mail merge when you are choosing a data source, *no* CSV format works - only
the OpenOffice database.  in that dialog you can click the OK button, but you
cannot get past step 3.

I have tried an Excel CSV file.  I have tried an address list creator CSV file.
 I have tried to hand-edit the CSV file thinking that the format was somehow
wrong (in some cases it was). I can't get past step 3 unless I use an openoffice
database.  No CSV file format I have tried is accepted (there are several
different formats of CSV). otherwise, sections 2 and 3 of step 3 are *always*
grayed out, and section 4 you can't click in but is not grayed out.

I have tried CSV without double quotes (Excel), and CSV with double-quotes on
everything, especially empty fields.
Comment 1 jmichae3 2008-01-13 08:35:50 UTC
I have figured it out!
mail merge doesn't like filenames with spaces in them (bad bug).  once created
with the create button, the address list shows up with its filename sans spaces
in the table column.  If you have put spaces in the filename, you are not
allowed to go past step 3.  
if you have not put spaces in the filename, you are allowqed to go past step 3
and  then go back to step 3 and pick a different address list.  sometimes in the
process of doing this, the table name of the one with spaces (which you
previously created) will disappear.

the problem is, mail merge hates spaces.  this is wrong.  the database likes
spaces.  CSV likes spaces.  mail merge should like spaces too.
Comment 2 michael.ruess 2008-01-14 08:18:27 UTC
Reassigned to HI.
Comment 3 Rainer Bielefeld 2008-01-14 15:21:09 UTC
That means the blanks in the file name and not '.csv' is the problem?
Please describe more exactly, not "name with spaces in it", but "my
addresses.csv" causes problems, "my_addresses.csv" does not.
Does that problem only appear using mail merge wizard or also using standard
print menu for mail merge letter?
Comment 4 jmichae3 2008-01-15 08:14:54 UTC
yes, the file name with spaces in it causes the problem.  example: "a b.csv" 
will not work correctly, but "a_b.csv" or "ab.csv" will work correctly.

I have not tried this yet, but I think that a database file that has spaces in 
the table name will not be properly processed. I noticed anything in the table 
column gets the spaces stripped out.  Anything with spaces in the filename 
column shows up as %20 and breaks.  this is a problem.

>Does that problem only appear using mail merge wizard or also using standard
print menu for mail merge letter?

I don't understand.  I was never able to get to printing when the problem 
occurred.  you couldn't get past step 3 of the mail merge process.
Comment 5 jmichae3 2008-01-15 08:32:24 UTC
the problem for some of my test files stems from the fact that only's CSV format is accepted, which uses double quotes, and UNIX 
newlines.  Excel is much more forgiving about quotes, but it and Notepad is not 
forgiving of the CSV format's UNIX newlines.

If you try to edit the CSV file using Notepad and correct the "missing" 
newlines as I did, it is now corrupted because Windows uses different 
newlines.  I thought I outlined this in a different bug report, but I am not 
sure.  I don't know whether this belongs in a separate bug report or not.

I suppose I should put in a feature request for CSV format compatibility with 
the OS platform you are on.  programming-wise, it's as simple in C/C++ as 
using "\n" in a string for a newline, and the OS-platform compatibility issue 
is solved.  I remember this works the same for Java.
Comment 6 Rob Weir 2013-02-02 02:59:59 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
Comment 7 Edwin Sharp 2014-03-13 11:40:14 UTC
csv with spaces in file name works.
AOO410m14(Build:9760)  -  Rev. 1573601
2014-03-03 17:47:48 (Mo, 03 Mrz 2014)
Win 7
Comment 8 Rainer Bielefeld 2014-03-13 12:37:50 UTC
(In reply to Edwin Sharp from comment #7)
> csv with spaces in file name works.

How did you test? I just tried, "Test Database.CSV" was not accepted by mailmerge wizard as address database, "TestDatabase.CSV" was accepted. Currently I do not trust my result 100% because I did not have enough time to do a careful test.

Please contribute test kit and step by step instruction how you successfully used a "name with blank.csv" as address database for mail merge.
Comment 9 Rainer Bielefeld 2014-03-13 12:39:25 UTC
My quick test in comment above with server installation of "AOO 4.1.0-Beta – German UI / German locale - [AOO410m14(Build:9760)  -  Rev. 1573601 2014-03-03 17:47:48]" on German WIN7 Home Premium (64bit)", own separate user profile.
Comment 10 Rainer Bielefeld 2014-03-13 12:44:30 UTC
Well, original report was incomplete and latest results still missing in Summary. 

I update Summary due to Comment 1

I wonder whether .odb or other sources with space in name will be accepted
Comment 11 Rainer Bielefeld 2014-03-13 12:49:48 UTC
I am pretty sure that you did your test with a .csv without blank in the name, what also works for me. So no need for additional info, except whether other file types work as address data source with blank in the name, what still has not been tested.
Comment 12 Edwin Sharp 2014-03-13 13:35:25 UTC
1. Create a comma separated value file with dummy data in notepad.
2. Save file as a b.csv. (there is a space between a and b)
3. File - Wizards - Address Data Source...
4. Other external data source - Next - Settings
5. Database type=Text - Next
6. Browse to a b.csv - Test Connection - OK - Next
7. Specify the type of files you want to access='Comma separated value' files (*.csv) - Finish - Next
8. Location=C:\...\a b.odb - Address book name=a b - Finish
9. Type some text into document
10. View - Data Sources - select a b
11. Drag a field into document
12. File - Print... - Yes
Mail Merge dialog appears as expected.
Comment 13 Rainer Bielefeld 2014-03-13 16:12:13 UTC
Yeah, now I see things clearly. It's really tricky, everything works fine, even a "name with blanks.csv" can be defined as address data source via 'Address Data Source Wizard', but in Mailmerge Wizard the same definition to assign a name with blanks.csv" as data source wizard fails. Really strange!

Steps how to reproduce Reproducible with server installation of "AOO 4.1.0-Beta – German UI / German locale - [AOO410m14(Build:9760)  -  Rev. 1573601 2014-03-03 17:47:48]" on German WIN7 Home Premium (64bit)", own separate user profile:

0. Download / Unzip Test Kit
1. From AOO Start center menu 'Tools -> Options -> Base -> Databases' 
   Delete all unknown / unnecessary Databases [OK]
2. Quit / Relaunch AOO
3. From AOO Start Center open new empty writer document
4. Menu 'File -> Wizards -> Adress Data source.... -> Other External source
   -> [Next] -> [Settings]'
5. Select Text -> [Next]
6. Browse for folder where you extracted test kit \ DSW 
   > No files will be shown
7. [Select] -> Next -> Selec CSV (radio button) -> Character set = "Wetern Europe
   (WIN-1252/WinLatin 1)" -> Check "Text Contains Headers" 
   Leave Field Separator comma, [Finish]
   > Pane shows "Sample database csv - Adress Datasource Wizard" and 
     "Sample database csv - Maiol Merge Wizard"
8. Click "Sample database csv - Adress Datasource Wizard" -> Next -> Next
9. In Step 5 Change Filename from Addresses.odb to AddressesDSW.odb and change
   Address book name from Addresses to AddressesDSW -> [Finish]
10. Do a quick test in Untitled 1 with <f4>: Database "AdressesDSW" will be
    shown with a single Table and Names "a1" and more

   That worked fine, now similar test from Mail Merge Wizard
14. In Text Document menu 'Tools -> Mail Merge Wizard -> Click step 3 ->
    [Select Address List]'
   > Shows "AdressesDSW" from test above
15. [Add]
16.  Browse for folder where you extracted test kit \ MMW
    -> Select "Sample database csv - Mail Merge Wizard.csv"  [Open]
17. Leave Field Separator comma, rest does not matter, 
    Character set = "Wetern Europe (WIN-1252/WinLatin 1)" 
    -> Check "Text Contains Headers" [OK]
    > An indicator that this did not work is that no table pane for this .csv 
      will be shown and that ok button leaves greyed 
18. Click "AdressesDSW" and back to second .csv -> [OK]
    >  It looks as if that would have worked, but you can not reach steps 
       behind  MMW step 3 with this approach
20. Do a quick test in Untitled 1 with <f4>: An Additional "Sample Database ..."
    will be shown, but Tables will be shown, this data base is unusable
So finally we can confirm the old report for AOO 4.1.0 Beta, it's impossible to add a .csv with blanks in name. That works fine with names without blanks (I did a test), and via Address Datasources Wizard also .csv with blanks in the name will be handled correctly. 

That has been some hard work!

Thank you for additional test, what showed up important details I never should have tested
Comment 14 Rainer Bielefeld 2014-03-13 16:13:45 UTC
Created attachment 82853 [details]
Test Kit

See comment above how to use
Comment 15 Rainer Bielefeld 2014-03-13 16:19:39 UTC
Additional Info:
(a) Same Problem in MMW LibO 4.2.1

Can you test with Linux whether the same problem does exist there?