Issue 85860 - Aqua: hang when user-event gets posted inside non-waiting cocoa-event-loop
Aqua: hang when user-event gets posted inside non-waiting cocoa-event-loop
Status: CLOSED FIXED
Product: gsl
Classification: Code
Component: code
680m243
Mac Mac OSX, all
: P3 trivial (vote)
: OOo 3.0
Assigned To: thorsten.martens
issues@gsl
: aqua
Depends on:
Blocks: 85798
  Show dependency treegraph
 
Reported: 2008-02-04 16:07 UTC by hdu@apache.org
Modified: 2008-08-05 17:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2008-02-04 16:07:52 UTC
To reproduce
- open a new native OOo for Aqua
- click on the OOo icon in the dock
- select something from the File->OpenRecent menu
- be careful not to move the mouse
=> the application doesn't open the document
because it hangs in Yield() waiting for any cocoa event
Loading the document only continues after  e.g. the mouse is moved.
Comment 1 hdu@apache.org 2008-02-04 16:09:52 UTC
Analyzing..
Comment 2 hdu@apache.org 2008-02-05 08:56:26 UTC
Problem was that inside a waiting-yield the user-event got posted while handling available cocoa events. 
The logic to send a wakeup-event into the cocoa-loop wasn't triggered in this situation.
=> fixed in CWS aquavcl05
Comment 3 hdu@apache.org 2008-02-05 09:09:18 UTC
Set target to CWS target.
Comment 4 philipp.lohmann 2008-02-19 21:15:26 UTC
please verify in CWS aquavcl05
Comment 5 b.osi.ooo 2008-03-03 17:53:54 UTC
I thought I had alread....
anyway: verified in cws aquavcl05: ok
Comment 6 Raphael Bircher 2008-08-05 17:05:46 UTC
Seems to be ok. The Document is not in focus after opening, but I think that's a
other problem

fixed in master

closing issue