Issue 90045 - Mail merge :: sending by e-mail does not work
Summary: Mail merge :: sending by e-mail does not work
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: DEV300m14
Hardware: PC Windows XP
: P2 Trivial (vote)
Target Milestone: ---
Assignee: caolanm
QA Contact: issues@sw
Keywords: regression
: 85388 85454 90709 (view as issue list)
Depends on:
Reported: 2008-05-27 22:39 UTC by cno
Modified: 2013-08-07 14:43 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

sample replacement. Copy the old one somewhere safe (12.32 KB, text/plain)
2008-05-30 12:37 UTC, caolanm
no flags Details
and what my log looked like (385 bytes, text/plain)
2008-05-30 12:37 UTC, caolanm
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cno 2008-05-27 22:39:36 UTC
- Writer document
- datasource
- drag fields in document
- 'Tools|Mail merge wizard'
- Step 8
- 'Send merged document as e-mail'
- select To and fill in Subject
- 'Send documents'
 - > some hdd activity is noticable, but no mails are send.
Comment 1 cno 2008-05-27 22:40:28 UTC
works OK in 2.4.0 > Regression
plus, iirc, cmc has to be in cc - sone
Comment 2 cno 2008-05-27 22:41:06 UTC
'sone' = 'done', of course :-\
Comment 3 cno 2008-05-27 22:49:37 UTC
In the mean time I doubt if this has to do with the mail merge wizard.
I see that the mail settings (Tools|Options|Writer|Mail Merge E-mail) that work
in 2.4.0, do not work in 300m14.
Maybe different (sub-)component?

Comment 4 michael.ruess 2008-05-28 06:26:28 UTC
Reassigned to HI.
Comment 5 h.ilter 2008-05-28 08:11:09 UTC
HI->cmc: Should be double to 85388.
Comment 6 caolanm 2008-05-28 08:53:41 UTC
Does it bother anyone at all that the code wasn't touched in all the time frame
from where it "worked" to where it "didn't work", or is this just a dumping exercise
Comment 7 caolanm 2008-05-28 08:54:03 UTC
What platform is this ?
Comment 8 cno 2008-05-28 09:03:14 UTC
@Caolan: Win XP SP2
 ( And that the code wasn't touched, does not necessarily mean that there is
nothing in it, that interacts with a change on another place. Might be
hypothetical, but nevertheless.. ;-) )
Comment 9 caolanm 2008-05-28 09:16:44 UTC
Well this will have to be reproducable on linux for me to do anything about it
as I've no windows
Comment 10 cno 2008-05-28 21:27:31 UTC
Hi Caolan,

Managed ;-) to install 3.0 Beta on SUSE.
The bug does not occur on that OS, so we must find another way to find out what
is happening.
Is a mail to dev@framework.OOo appropriate??
Thanks - Cor
Comment 11 caolanm 2008-05-29 17:49:47 UTC
It's only a fairly simple python script itself. I wonder if under windows the
stderr stuff works, e.g. find mailmerge py in the program dir and with a
texteditor change dbg = False to dbg = True and run office from a cmd window and
see does it say anything at all
Comment 12 cno 2008-05-29 20:21:23 UTC
I've tested as suggested, but noticed no difference.
Do I have to give a certain argument when starting soffice.exe from the cmd window?
Comment 13 caolanm 2008-05-30 12:36:37 UTC
So I installed the OOo beta under windows xp under qemu and test "test settings"
appeared to work for me.

So can you take the attached and copy it over the original with it, you should find it in c:\Program
Files\\Basis 3.0\Program (please check to make sure it is already
there, just to double check anything unusual that might be relevant) 

Then do the test settings and a file should be created as 


attach that file here then and that might give us some debugging information to
check against. I'll attach my own one for reference
Comment 14 caolanm 2008-05-30 12:37:29 UTC
Created attachment 54087 [details]
sample replacement. Copy the old one somewhere safe
Comment 15 caolanm 2008-05-30 12:37:48 UTC
Created attachment 54088 [details]
and what my log looked like
Comment 16 caolanm 2008-06-04 09:41:24 UTC
*** Issue 85388 has been marked as a duplicate of this issue. ***
Comment 17 caolanm 2008-06-10 11:22:14 UTC
any change you could try the replacement debugging script and see what gets logged ?
Comment 18 h.ilter 2008-06-16 10:28:24 UTC
*** Issue 90709 has been marked as a duplicate of this issue. ***
Comment 19 caolanm 2008-06-18 19:13:14 UTC
cmc->tml: As our resident windows hacker, any chance you can reproduce this
windows problem, and see if the replacement .py is able to capture any information ?
Comment 20 cno 2008-06-18 19:41:58 UTC
@cmc: a pity that the things we tried/ discussed (by mail) didn't help so far
@tml: if any info of what/how I tested can be of help, pls let me know
Comment 21 timrichardson 2008-06-24 21:20:34 UTC
I see this same problem on Ubuntu in OOO 2.4.1
Comment 22 cno 2008-06-24 22:40:01 UTC
Hi Tim,
I could not reproduce with 2.4.x / 3.0Dev on Linux.
Which OOo vesion do you have? The official build from Sun, or the one shipped
with Ubuntu?
Comment 23 timrichardson 2008-06-26 06:08:10 UTC
I have the version from Ubuntu, probably hardy-updates.
not only is the "test settings" option broken, but the email sending of mail
merge also fails. It just stops. No progress in sendin mails. So this bug is
more serious than it seems, because the entire fuctionality of email merge is

I am encouraged that you can't reproduce this. I thought that it must be an SMTP
server problem.However, in Evolution I can configure my SMTP server as port 25
with no security, and it happily sends mail. Openoffice mail merge fails. No
error messages, it just hangs. I assume you realise that this is different to
sending mail in OpenOffice writer from the  File menu, because the mail-merge
feature attempts to connect directly with an SMTP server. From google I see that
many people are reporting the same problem as me. So I am puzzled that you can't
reproduce it. Could you give some more details of your settings? Which port,
what type of server authentication did you set up?

Comment 24 donatherton 2008-06-27 15:52:11 UTC
The advice on
seems to help.

I used the command

sudo unopkg add --shared /usr/lib/openoffice/program/

that being the path to After doing this OO was able to connect to
the smtp server.

However, I still could not send the emails. I got the following error:

<class 'smtplib.SMTPServerDisconnected'>: Connection unexpectedly closed,
traceback follows
  /usr/lib/python2.5/ in function getreply() [raise
SMTPServerDisconnected("Connection unexpectedly closed")]
  /usr/lib/python2.5/ in function docmd() [return self.getreply()]

Ubuntu Hardy KDE OO v2.4.1
Comment 25 timrichardson 2008-07-01 20:50:14 UTC
Also broken Debian/sid. I filed a bug report there.
Comment 26 timrichardson 2008-07-01 21:14:27 UTC
In Ubuntu 8.04

sudo unopkg add --shared /usr/lib/openoffice/program/

fixed the problem. I can connect to the server and send email, even with SSL
connection security enabled.

Comment 27 timrichardson 2008-07-02 09:28:18 UTC
for sake of completeness, the workaround fixes Debian/Sid as well.
Opinion of the Debian maintainer is that this is an upstream problem.
Comment 28 landofsinim 2008-07-07 11:00:53 UTC
Running OO 2.4.1 if have been able to get it to start the merge then it freezes
locking the whole program. Running on Hardy 8.04 I think it may have something
to do with the Writer.xcu file, not sure though as I have played with the true
and false on all the options
Comment 29 stefan.baltzer 2008-07-18 18:14:16 UTC
This issue has no target set but is considered a OOo 3.0 Final blocker... 
Can someone please sort out if this a reproducible problem (in DEV300...) that
affects users in large scale AND that can be fixed with agreeable amount of risk
before OOo 3.0 final?
Put Jacqueline on CC.
Comment 30 jr 2008-07-18 20:08:21 UTC
I'm sorry, I can't reproduce this problem. Tried with BEA300 m2, DEV300 m19 and
DEV300 m25 - Win XP. Sending E-Mails via Mail Merge works fine here.
Comment 31 cno 2008-07-18 23:16:40 UTC
Made enthusiastic ;) by Jacqueline's test result, I tested again on Win XP.
This time with Dev300_m23. And everything works OK there.
So seems solved for me, but without anyone knowing how.. Also in the mean time
there are quite some others that reported the problem. So I'm a bit cautious.
Comment 32 stefan.baltzer 2008-07-21 13:27:20 UTC
SBA: Since the initial submitter can not reproduce this, I set this one to
Set Target to OOo 3.1. Remove link to show stopper issue.

Feel free to submit a new issue if you can offer a clear reliable reproduction
in DEV300_m26 or younger and name the ID in here. Having this issue "mutate
further" makes not much sense.
Comment 33 cno 2008-07-21 23:21:00 UTC
I h*te this kind of bugs that cost me hours to test, not finding a soluting and
just disappearing in the mist :-(  (Sorry, had to relieve my feelings)
But of course I agree with target 3.1. 
My intention is to close this issue, if I do not find the bug in any of the next
builds before 3.0-final.
Comment 34 stefan.baltzer 2008-07-22 10:29:17 UTC
SBA->Cor: I agree to close this one. I was just waiting for you to propose it :-)

I understand that nailing down an issue sometimes can cost time. Without a
"valuable outcome" in terms of "a real issue to fix" this might be unsatisfying.
But on the other hand... How often is the reproduction two- or three-clicks, but
for the developer days to riddle and fix... Yes I also prefer those, too. But
counting in larger numbers, they do co-exist with the vanishing ones like this.
Recent examples for "the easier part for the tester" are 91928 and 91643... :-)
Comment 35 caolanm 2008-07-24 10:01:24 UTC
*** Issue 85454 has been marked as a duplicate of this issue. ***