This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 35196 - [TTV] "List Options" should perhaps be renamed
Summary: [TTV] "List Options" should perhaps be renamed
Status: NEW
Alias: None
Product: platform
Classification: Unclassified
Component: Outline&TreeTable (show other bugs)
Version: 3.x
Hardware: All All
: P3 blocker (vote)
Assignee: Martin Entlicher
Keywords: UI
Depends on:
Reported: 2003-07-29 19:08 UTC by David-john Burrowes
Modified: 2010-10-07 11:33 UTC (History)
1 user (show)

See Also:
Exception Reporter:


Note You need to log in before you can comment on or make changes to this bug.
Description David-john Burrowes 2003-07-29 19:08:43 UTC
When it was originally designed, the tree table
view was given a contextual menu item called "List
options" which displayed options for changing how
information was shown in the table (which, to the
end user, should be thought of as a list of
objects.. hence the name "List").
However, in the debugger at least, the "list" is
basically the same as the whole view, and so it is
probably more reasonable to name this menu item
"View Options" (or the equivalent name in the new
windowing system).  I'm not sure, however, where
this component is used throughout the IDE, and
whether this name is appropriate to all contexts.