Issue 115712 - When the saved file is moved, the image file changes.
When the saved file is moved, the image file changes.
Status: CONFIRMED
Product: Impress
Classification: Application
Component: code
OOo 3.2.1
Unknown Windows XP
: P3 trivial (vote)
: ---
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-22 06:33 UTC by marines
Modified: 2013-04-02 19:23 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Illustrated Test Step Slides (136.50 KB, application/vnd.ms-powerpoint)
2011-09-25 04:08 UTC, Nancy
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description marines 2010-11-22 06:33:53 UTC
I've reproduce this behaviour on OpenOffice.org 3.2.1.
Running Win XP SP3.

When the saved file is moved, the image file changes.

Steps to reproduce:
 1. Create a new presentation.
 2. Go to menu Insert-> Movie and Sound
 3. Choose a image file.(ex:XXX.avi)
 4. Save and close the file.(ex:C:\test.odp)
 5. Choose and move the saved file.(ex:C:\→C:\Program Files)
 6. Open the file again.
 7. Image file changes to "?".

I wouldn't like change the image file even if you move the saved file.
Comment 1 wolframgarten 2010-11-22 08:49:51 UTC
Did you change the location of the video, too? Normally the path to the inserted
file is saved absolute, not relative. Changing the of the odp file does not
affect functionality. 
Comment 2 airez 2011-05-21 20:46:24 UTC
I tried to reproduce this issue with OOo-dev 3.4.0. DEV300m106 (Build:9582)
Platform: Windows 7 Professional 64bit

Followed steps initial reporter provided. Change in those steps was in step 4. 
4.1. I saved presentation to same folder as video file used in that presentation 
4.2. I saved presentation to different folder as video file used in that presentation 
 
This issue is reproducible if I save presentation to the same folder with the video file at first and then move to a different folder. In that case video changes to "?" after the move. 
If I save presentation to different folder from video file, video does not change when presentation is moved. 

Video file was not moved in either of those cases.

If I move video file to same folder with presentation again after video was changed to "?" with first move and then reopen presentation, video is shown correctly again. 

If I saved presentation file to same folder as video and then moved video file from that folder, video was changed to "?" in presentation.
Comment 3 Nancy 2011-09-25 04:07:41 UTC
I was able to reproduce this behaviour on the following system configuration:
System Configuration:
OpenOffice – Ooo-Dev 3.4.0 (OOO340m0 – Build: 9583) 
Windows Vista Home Premium – Service Pack 2.

I reproduced this test because I was curious if the video still played after the file had been moved and the ? appeared on the slide. I’m assuming from the reports that it does not, but neither report explicitly stated that it didn’t. As a presenter I would be mortified to find out my video didn’t work during my presentation as a result of a simple file move. 

Test #1 – Replicating the initial problem reported (See Attached Presentation for Graphical Representation of Steps and Results of Test #1) 
Steps to reproduce – Inserting a Movie and Sound
1.	Create a new presentation.
2.	Go to menu Insert -> Movie and Sound
3.	Choose an .avi file. (This test used a 2.03 MB .avi file located in the My Documents Folder on my computer)
4.	Save and close the presentation file into the same file that the movie file is stored. (This test saved the file in the My Documents Folder on my computer)
5.	Using Windows Explorer, move the presentation file that was saved in Step 4 from the saved location into a new location outside the My Documents folder. (This test moved the file to c:\Temp). 
6.	Return to OpenOffice and open the file.
7.	On the slide the movie file changes to a “?”. 
8.	Movie can no longer be played or accessed from the presentation.

Test #2 – Repeat the above steps with an audio file, rather than a video file. 
Results of Test #2 – Test#2 saw the same behaviour. The audio file changes to a “?” after the file move and the audio file can no longer be played or accessed from the presentation. 
In both cases moving the presentation file back to its original location and reopening displays the movie/audio correctly and the movie/audio can be accessed and played. Also moving both the presentation file and the movie/audio file to the new location and reopening displays the movie/audio correctly and the movie can be accessed and played. 
Repeating Test #1 & Test #2 in MS Powerpoint demonstrated different behaviour. After the presentation file was moved, the movie/audio remained accessible and could still be played within the presentation. The file move had no impact on the movie or audio when using MS Powerpoint. 

Test #3 – Repeating this test with an image file
Since an image file is inserted in the same menu bar I wondered if it had the same behaviour. 
Inserting an Image:
1.	Create a new presentation in OpenOffice. 
2.	Go to menu Insert -> Picture -> From File
3.	Select an image file from the My Documents folder.  (This test used a .jpeg file)
4.	Save and close the file. (This test saved the file in the My Documents Folder)
5.	Using Windows Explorer, move the presentation file that was saved in Step 4 from the saved location into a new location outside the My Documents folder. (This test moved the file to c:\Temp).
6.	Return to OpenOffice and open the file.
7.	The presentation document opens without the ? on the slide and the image is displayed correctly.

Test #4 – Repeated test 4.2 in Comment #2 (Also illustrated in attached PowerPoint file)
I repeated the test 4.2 in Comment#2 and found 2 situations – one in which the test passes (I.e. the file is not affected and remains accessible) and one in which the test fails (the video is replaced with a “?” and is not accessible)  
Steps to reproduce – File is not affected and remains accessible
1.	Create a new presentation in OpenOffice. 
2.	Go to menu Insert -> Picture -> From File
3.	Select a video or audio file. (For this test the video file is in C:\VideoFolder)
4.	Save and close the file. (This test saved the file in the C:\PresentationFolder)
5.	Using Windows Explorer, move the presentation file that was saved in Step 4 from the saved location into a new location outside the My Documents folder. (This test moved the file to c:\PresentationNewFolder).
6.	Return to OpenOffice and open the file.
7.	The document opens without the ? on the slide and the video is displayed correctly.

Steps to reproduce – File is affected, ? appears and the file is not accessible
1.	Create a new presentation in OpenOffice. 
2.	Go to menu Insert -> Picture -> From File
3.	Select a video or audio file. (For this test the video file is in C:\VideoFolder)
4.	Save and close the file. (This test saved the file in the C:\PresentationFolder)
5.	Using Windows Explorer, move the presentation file that was saved in Step 4 from the saved location into a new location outside the My Documents folder. (This test moved the file to c:\temp\PresentationNewFolder).
6.	Return to OpenOffice and open the file.
7.	The document opens with the ? on the slide and the video is not accessible.

Why fix this bug? 
The impact of a bug like this could be significant to the user of this product. As a presenter I am often moving my presentation files between computers, network shares, or USB keys. If a presenter wasn’t aware of this issue they may be left scrambling to replace a missing video file just prior to giving a presentation. Or worse, they may not notice until the presentation is taking place. Since the MS Powerpoint product handles the moving of a presentation file after the video or audio has been added users would expect OpenOffice to have the same behaviour. If this was to happen to presenter during a presentation they would likely be very nervous about trusting this product again. 

Possible Issue
I know that comment#1 states that this shouldn’t be a problem if the presentation file is moved since the OpenOffice product is using absolute instead of relative file paths. However, it is possible that OpenOffice is actually using a relative file path instead of an absolute file path since in these tests only the Presenation File was moved and the audio/video files stayed the same? 

Note: With this report this bug has been reproduced on Windows XP, Windows Vista and Windows 7 Professional.
Comment 4 Nancy 2011-09-25 04:08:43 UTC
Created attachment 76828 [details]
Illustrated Test Step Slides
Comment 5 Brian R 2011-09-26 04:36:09 UTC
I was able to replicate this bug using a Windows 7 Ultimate x64 system with OpenOffice version 3.3.0 (OOO330m20).  I followed the same steps of the original poster.  

This mishap is a legitimate issue for most users.  Often, .odp files are moved and are expected to link the videos contained in them correctly.
Comment 6 Rob Weir 2013-02-02 02:59:23 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 7 Rob Weir 2013-04-02 19:23:53 UTC
Confirmed on OOo 3.3.0 per comments