Issue 122255 - [sidebar] Store panel expansion state (non persistent)
Summary: [sidebar] Store panel expansion state (non persistent)
Status: RESOLVED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 4.0.0-dev
Hardware: All All
: P3 Normal (vote)
Target Milestone: 4.0.0
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 122256 (view as issue list)
Depends on:
Blocks: [sidebar]
  Show dependency treegraph
 
Reported: 2013-05-08 07:57 UTC by Andre
Modified: 2013-07-11 13:56 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Andre 2013-05-08 07:57:32 UTC
Currently the expansion state of sidebar panels is reset to initial values on every configuration change.  Storing this state would enhance usability.

Storing the expansion state persistently would be further enhancement but
- requires more work to implement
- may confuse users.
Comment 1 Andre 2013-05-08 09:41:37 UTC
*** Issue 122256 has been marked as a duplicate of this issue. ***
Comment 2 SVN Robot 2013-05-08 09:48:37 UTC
"af" committed SVN revision 1480209 into trunk:
122255: Store sidebar panel extension state (non persistent).
Comment 3 Andre 2013-05-08 09:50:11 UTC
Storing the modified expansion state flags in the data structures of the ResourceManager class.