Issue 34896 - Still can't open files in MS network neighborhood
Summary: Still can't open files in MS network neighborhood
Status: CLOSED DUPLICATE of issue 51026
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: 680m54
Hardware: PC Windows 98
: P3 Trivial with 4 votes (vote)
Target Milestone: AOO Later
Assignee: hennes.rohling
QA Contact: issues@framework
: 43477 49645 (view as issue list)
Depends on:
Reported: 2004-10-01 22:59 UTC by drc
Modified: 2007-05-22 11:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Screenshot of browsing window and error message (20.06 KB, image/png)
2004-10-01 23:01 UTC, drc
no flags Details
Screenshot showing failure to load (29.28 KB, image/png)
2004-11-20 17:25 UTC, drc
no flags Details
Path details for plog2.sxw (18.11 KB, image/png)
2005-05-13 01:05 UTC, drc
no flags Details
Debian (sarge) screenshot (190.87 KB, image/png)
2005-10-24 10:59 UTC, drc
no flags Details
And the current one I meant to attach..... (180.21 KB, image/png)
2005-10-24 11:37 UTC, drc
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description drc 2004-10-01 22:59:05 UTC
Developer Build 1.9.m54 (680_m54) on W98SE
talking to Samba Server 2.2.7a-security-rollup-fix

Ressurects issue 5149 and its many, many duplicates.
I am fighting a rearguard action keeping my users from the frustrations of this 
defect by mapping drives for them.  I had hoped OOo v2 might have fixed it.

In my experience OOo will not open files served by Samba on Linux found by 
browsing the MS network.  If the network shares are mapped as drives they are 
found, so it can't be an obvious permissions issue.

MS W98SE peer-to-peer seems to work.

Screenshot follows....
Comment 1 drc 2004-10-01 23:01:04 UTC
Created attachment 18070 [details]
Screenshot of browsing window and error message
Comment 2 thorsten.martens 2004-10-05 07:48:18 UTC
TM->HRO: Please have a look, thanks !
Comment 3 drc 2004-11-20 17:21:22 UTC
Still present in 1.9.62 - see screenshot.

The file was successfully saved to the share after browsing in the Save_as
window via Network neighborhood.

I worked for a company that went broke because it couldn't understand that
sometimes you are a victim of two bugs.  Yes - there is a problem with Samba. 
It doesn't work the same as a Windows share because I can open OOo docs wia a
true Windows Network Neighborhood share.

There is also a problem with OpenOffice.  I can open documents with all my other
applications over a Network Neighborhood share to my Samba server, but not
OpenOffice.  It doesn't matter whether I browse and click the document to load
OOo, or use File Open and browse Network Neighborhood, the result is the same.
Comment 4 drc 2004-11-20 17:25:33 UTC
Created attachment 19515 [details]
Screenshot showing failure to load
Comment 5 hennes.rohling 2004-12-17 10:59:48 UTC
Comment 6 rgrange 2005-02-24 16:30:55 UTC
I was still seeing this problem on 1.9.65 on Windows 2000 Pro.  Files were being
stored on a Quantum Snap Server, but I believe it also uses Samba for the actual
Comment 7 jnegron 2005-05-06 10:18:26 UTC
Unable to open files in Samba server while browsing from OOo 1.9.100-EN (Win98SE-ES)
OOo allows to browse, find file and then reports that it can't open file( while
showing full path), as it doesn't exist.

Message is in english, OS spanish.

Mapping drive in Windows works. I can live with workaround, but may be a killer
for others.
Comment 8 hennes.rohling 2005-05-12 12:28:23 UTC
Existance and being able to open a file is something different. Other
applications may not use file locking, share modes as OOo does.

No problems with Samba servers (Linux) and trying to open files from Windows here.

Maybe optlocking is misconfigured  but as you said mapping it to a drive works.

So the only thing i can imagine is that there's an issue with the UNC path, some
unsupported characters, a bug only for files in the root of a share etc.

Need a little bit more information as I can't reproduce the issue.

Comment 9 drc 2005-05-13 01:03:04 UTC
Attached png showing path.

I suspect it's an issue with the type of path.
I'm not clever enough to change the oplock settings in Samba from the default
(which I think is enabled) but on my little home network there's only me.  At
school I share four Sambas with 350 other terminals.  The problem is the same in
both places (and I put all the Sambas in).

If it sheds any light on the problem, OOo seems to be quite happy writing out to
a network path. but the same instance will not then File Open what it has just
File SaveAs-ed, even after a File Close.

The Save As dialogue box has a tighter display format (more files visible in
narrower columns) than the File Open dialogue. Whilst it may be totally
spurious, it suggests they were programmed by different people - or at least at
different times.  Do they handle the paths differently?
Comment 10 drc 2005-05-13 01:05:29 UTC
Created attachment 26078 [details]
Path details for plog2.sxw
Comment 11 drc 2005-05-13 01:16:13 UTC
Oops - sorree
The file description on the attachment should read 'Path details for plog2.sxc'

I'm too tired for this....
Comment 12 tomleonard 2005-06-18 02:50:13 UTC
Still can't open file in release 1.9.104.
OO running on W98SE system (Breeze), file on W2k system (\\Orion\d\My
Documents\DragonHeart\Bind.doc).  With Write started, tried to open by file/open
and browsing Network Neighborhood.  No Samba involved.

The network is fine.  I had just created the file in Word on Breeze and saved it
to Orion over the network.  I closed Word before trying to open the file in OO.
Comment 13 mci 2005-07-26 12:21:33 UTC
*** Issue 49645 has been marked as a duplicate of this issue. ***
Comment 14 mci 2005-07-26 12:22:40 UTC
*** Issue 43477 has been marked as a duplicate of this issue. ***
Comment 15 devtee 2005-09-09 02:23:39 UTC
Similiar to drcowsley and others on this issue, I have a Quantum Snap Server and
another Samba server (v3.0.10 on Slackware 10.1) and have the same reported issues. 

Other things I have noticed :

- create a document in OOo v2b2 under Win98SE and save it on the Snap Server and
to the Samba server with no problems, but then I can't open them.

- create a document in OOo v2b2 under WinXP SP2 and try to save it on the Snap
Server, it fails, but saves successfully to the Samba server

- create a document in OOo v2b2 under Win98SE AND in OOo v2b2 under WinXP SP2,
  and try to save it as test.odt to the network share "test-folder" 
  on another Win98SE machine named A_server, I get the following dialog box :

     Error saving the document Untitled1: 
     \\A_server\test-folder\test.odt does not exist

with an OK button. Clicking the OK button, the dialog box clears and a second 
dialog box appears :

     Error saving the document Untitled1:
     General Error.
     General input/output error.

with another OK button which clears the dialog box.

- in OOo v2b2 under Win98SE, opening test.odt on the network share "test-folder"
on another Win98SE machine named A_server, it opens successfully. On saving it,
I get the aforementioned second dialog box, namely 

     Error saving the document test.odt:
     General Error.
     General input/output error.

- in OOo v2b2 under WinXP SP2, opening test.odt from the Win98SE share, Snap
Server and Samba server works. Saving it fails with the Win98SE share and the
Snap server, but works with the Samba server.

- If I use OOo v1.1.4, I do NOT get these problems, saving and opening files
to/from a Win98SE share, Quantum Snap server and Samba server.

Dev T
Comment 16 juanrey 2005-09-28 08:44:46 UTC
I do not know if I should open a new issue but I have made an inquiry;

We share files hosted on an NT4 BDC server and I have not been able to open
those files from "Windows Explorer" or from "Total Commander" with 19mXX. 

But I tried to open it from the OO File->Open menu and it works... so I think It
maybe is a windows shell related issue.

Comment 17 juanrey 2005-09-28 08:55:08 UTC
I have tested the same behaviour with files hosted on Windows 2003 server and it
works both ways, Doble click opening on "Windows Explorer" and opening form the
"Open->File" menu.

Comment 18 sarsenlintel 2005-10-07 14:24:19 UTC
I'm seeing similar behaviour with the RC1 build (depending upon file type).
Using Win 98SE, files located on Samba 2.28 (mdk 9.2) at \\Odin\My Documents

Created a file called ooo_test.odt, Writer saved it with no problem, but refused
to open it again "does not exist". The file also won't open from Explorer. If I
map a drive to \\Odin\My Documents it works fine.

Tried again but saved as a txt file ooo_test.txt and I get "Error saving
document Untitled1: \\Odin\my documents\ooo_test.txt does not exist". Followed
by "Error saving the document Untitled1: Object not accessible. The object
cannot be accessed due to insufficient user rights." Though it still creates the
file - I can browse to it and open it in Notepad (or any application other than
OOo). Same thing happens with a .doc file

One other odd thing I noticed, if I create the file lower down in the directory
structure, say:
\\odin\my documents\chelle\ed psych assign 1\done\new_test.txt and then browse
to it in explorer and right-click | View in Notepad I get the following message:

"\\Odin\my Documents\Chelle\EDPSY~!Q\done\new_test.txt You do not have
permission to open this file. See the owner of the file or an administrator to
obtain permission"

But if I simply left-click on the file it opens fine (in Notepad). I checked the
permissions and all are as they should be, only OOo seems to have a problem with
the test files (that it created).
Comment 19 drc 2005-10-24 10:41:42 UTC
In case it sheds some light on things, I have the same problem trying to load
from a Samba server when the client is a Samba client on the up-to-date Debian
Sarge.  This is an older versin of OpenOffice but the completely open, wholly
non-Microsoft setup might clarify things.

Screen shot ....
Comment 20 drc 2005-10-24 10:59:38 UTC
Created attachment 30768 [details]
Debian (sarge) screenshot
Comment 21 drc 2005-10-24 11:37:13 UTC
Created attachment 30770 [details]
And the current one I meant to attach.....
Comment 22 grahamtapper 2005-11-27 10:51:30 UTC
I have also just discovered this problem with the latest version of OpenOffice.
 I am sure that it didn't exist with previous versions.

I am running WindowsMe on a very old Toshiba Tecra8000.  I have a network
attached storage (NAS) device, a Buffalo Technology LinkStation Network Storage
Center, which I believe runs a Linux operating system variant under the covers.

I have no trouble accessing the various folders on this device from anywhere and
with anything except OpenOffice.  When I go into Writer, for instance, and via
Open navigate to the precise file I want to open via My Network Places, Writer
tells me that the file does not exist!

I can download the file to a local folder and have no problem opening it then. 
I can also Map the network folder to a drive letter and then Writer will open
it.  That is a temporary workaround.

This is clearly  a bug in OpenOffice that needs to be fixed.
Comment 23 kpalagin 2007-05-22 11:17:14 UTC
I think this issue is dup of
Resolving as such.

For users with underscores in server names problems is solved in

*** This issue has been marked as a duplicate of 51026 ***
Comment 24 kpalagin 2007-05-22 11:19:12 UTC
and closing.