Issue 65391 - page preview changes text position in table cell
Summary: page preview changes text position in table cell
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.0.2
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
: 75321 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-05-15 12:47 UTC by schmieta
Modified: 2017-05-20 11:17 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
text in a table cell changes its vertical position when pressing 'page preview'. (9.14 KB, application/vnd.sun.xml.writer)
2006-05-15 12:49 UTC, schmieta
no flags Details
screen print showing correct vertical position with page preview (27.44 KB, image/png)
2007-12-02 20:46 UTC, cno
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description schmieta 2006-05-15 12:47:38 UTC
In a writer document opened with openOffice.org 2.0.2 the text position in a 
table cell is set to 'bottom'.
When pressing the 'page preview'-button, the text position changes to 'top' even 
before the page preview itself has opened. There the text is shown in the wrong 
(upper)position. After closing page preview the text position only changes back 
to 'bottom' after the cell has been mouse clicked.
The same document in openOffice.org 1.1.3 behaves normally.
Comment 1 schmieta 2006-05-15 12:49:56 UTC
Created attachment 36480 [details]
text in a table cell changes its vertical position when pressing 'page preview'.
Comment 2 schmieta 2006-05-15 12:52:22 UTC
Please watch the line where it says 'Barverkauf/Rechnung Nr.:' in the top line 
of the right table. 
Comment 3 Rainer Bielefeld 2006-05-15 17:40:45 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" and can
ocnfirm the reported effect: Text "Barverkauf/Rechnung Nr.:" and also the
EURO-symbols move to the top of the cells when I click "page preview" and and
move back to the bottom after I disable pp.

I used the test file without images for my tests.

The effect remains If I change printer.

Sometimes the vertical misalignment remains even after I finished pp., I have to
click into the document until the effect disappears.

It seems that PDF export and printout from pp always shows vertical misaligned
text as visible in the preview.

If misalignment remained after I finished pp, printout and PDF export from
normal page view will also show misalignment as visible on the screen.

@schmieta:
Pls. specify your Platform and OS!
Can you attach a new, more simple document using only standard OOo formattings
to reproduce the problem?
Comment 4 philipp.lohmann 2006-05-15 17:49:35 UTC
Same effect on Linux; however i don't think this is a gsl issue but probably
more an issue of writer itself.

For that matter the same behaviour applies if all the 6.0/7 compatibility
choices in tools->options->Writer->Compatibility are switched off

pl->ama: I think this is something for writer
Comment 5 michael.ruess 2007-03-12 16:47:32 UTC
*** Issue 75321 has been marked as a duplicate of this issue. ***
Comment 6 Martin Hollmichel 2007-09-10 13:53:08 UTC
move to 3.x accroding http://wiki.services.openoffice.org/wiki/Target_3x
Comment 7 cno 2007-12-01 18:57:25 UTC
Hi,
While lokking at some table issues, I checked this in 2.3.0 and 680m8.
I can't see the undesired behaviour -> probably fixed?
Comment 8 Rainer Bielefeld 2007-12-02 06:56:38 UTC
I checked with "OOo-dev 2.3.1  WIN XP: [680m8(Build9236)]" and still saw the
problem.
Comment 9 cno 2007-12-02 20:45:07 UTC
Interesting. Not to say strange ;-)
I focussed on the comments from schmieta Mon May 15 11:52:22 +0000 2006 : "...
'Barverkauf/Rechnung Nr.:' in the top line of the right table."
I'll attach a screenshot showing my result: the line stays bottom during page
preview.
Comment 10 cno 2007-12-02 20:46:00 UTC
Created attachment 50053 [details]
screen print showing correct vertical position with page preview
Comment 11 Rainer Bielefeld 2007-12-03 04:32:23 UTC
Yes, that detail seems to look oK in the pae preview, but what is after you
changed back to the normal view or when you select page preview a second time?
With "OOo-dev 2.3.1  WIN XP: [680m8(Build9236)]" the reported problem still is
visible, the text position is changed. 
Comment 12 cno 2007-12-03 06:48:41 UTC
Both in 2.3.1RC1 and 680m8 I can open and close page preview till my weight has
fallen to an once, no change in the position of that text.
A Writer / table setting fooling us?
Comment 13 andreas.martens 2007-12-03 08:56:17 UTC
It's still reproducible. This problem occurs with cell alignment at bottom in
frame anchored at page.
Workaround: Do not use this alignment or do not use this anchor type.
Comment 14 cno 2007-12-03 09:17:30 UTC
If I 
- empty the frame 'Rahmen3' (anchored at the page),
- put in one table cell
- set the height to a few cm
- copy the orig. text 'Klavier Garbe' in the cell
- align the cell bottom
...
the position doesn't change for me in (repeated) page preview

Might be my fault, but I just can't reproduce it here :-)
Comment 15 Oliver-Rainer Wittmann 2007-12-03 09:52:03 UTC
accepted - adjusting target to OOo 3.0
Comment 16 Oliver-Rainer Wittmann 2008-04-28 11:25:25 UTC
Due to limited resources re-target to OOo 3.x
Comment 17 Oliver-Rainer Wittmann 2008-04-28 11:26:12 UTC
.
Comment 18 Marcus 2017-05-20 11:17:57 UTC
Reset assigne to the default "issues@openoffice.apache.org".