Issue 7599 - OpenOffice.org mime types are rejected as attachments
Summary: OpenOffice.org mime types are rejected as attachments
Status: RESOLVED FIXED
Alias: None
Product: Infrastructure
Classification: Infrastructure
Component: Bugzilla (show other issues)
Version: current
Hardware: All All
: P3 Trivial (vote)
Target Milestone: CEE Rubicon
Assignee: Unknown
QA Contact: issues@www
URL:
Keywords: oooqa
: 598 6937 12204 22490 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-09-09 07:48 UTC by Frank Schönheit
Modified: 2009-01-23 11:19 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Frank Schönheit 2002-09-09 07:48:30 UTC
Tried to create an attachement to an IssueZilla bug, which was a OpenOffice.org
Writer document (*.sxw). As MIME type, I entered application/vnd.sun.xml.writer,
which, AFAIK, is the proper type for these documents.
This was rejected with a message "You must select a legal mime type.
'application/vnd.sun.xml.writer' simply will not do.".

This way, people are forced to use a more "generic" MIME type, like
"application/octet-stream", which unnecessarily complicates opening attachements.
Comment 1 lsuarezpotts 2002-09-10 01:27:54 UTC
Hi
IZ is just an app. to implement this enhancement would take a very
long time, as it is not, afaik, on the roadmap.
closing with wontfix.
louis
Comment 2 Frank Schönheit 2002-09-10 08:08:06 UTC
Sorry, I do not really see your point. I understand that Issuezilla is
"just an app", but I do not see how this contradicts the possibility
to be enhanced.
Furthermore, "would take a long time 'cause it's not on the roadmap"
is not really satisfying. I continue to think that IssueZilla should
integrate seemless with OpenOffice.org (finally, IssueZille is _about_
OpenOffice.org), and the need to save my .sxw attachements (or click
away some dialog every time, or associate such a generic mime type as
"application/octet-stream" with OpenOffice.org) does not really sound
like "seemless" to me.
What would be the effort to put this enhancement onto the roadmap?

Sorry, but rejecting an enhancement "because it's not planned"
(without discussing about feasibility and reasonability) is somewhat
.... well, unorthodox at least.
Comment 3 stx123 2002-09-10 09:20:47 UTC
Hi, may be this should be considered for a future version of SC's
bugtracking system.
Comment 4 lsuarezpotts 2002-09-10 23:40:44 UTC
Frank
You seem to have misinterpreted my comments and I regret I was not
clearer. You needed to specify this as an enhancement you wish
implemented.
It would be nice if SourceCast were to do all that Ooo wanted it to
do. It may be designed so that it does accept the mime type. I will
request it. 
IssueZilla itself will be replaced in the near future--next year. I
would hope that its replacement, Scarab, would accept the mime types.
louis 
Comment 5 Frank Schönheit 2002-09-11 07:23:43 UTC
Louis, thanks for the clarification. Sorry for ranting (ehm - it's an
inborn problem of mine to rant before asking, I really have to work on
this :). I really read your original comment as basically "won't do
because it's not planned". Sorry.

I am really looking forward to this often-mentioned uber-tool Scarab :)

Frank
Comment 6 lsuarezpotts 2002-09-20 00:18:25 UTC
Hi
passing on to support.
Brian/kenneth: would you update the whiteboard status of this?
I'd like to see, too, about the process of adding mimetypes. 
thanks
Louis 
Comment 7 Unknown 2002-09-21 01:04:15 UTC
Opened internal RFE.
Comment 8 Unknown 2002-10-29 23:42:16 UTC
Hi Frank,

I raised this to our enhancement engineering person & he is going to
look into this issue.
I will update this issue with the response upon receiving this
information.
Let us know if this is not an adequate response to this issue.
Thanks,

Eric
Comment 9 Unknown 2002-10-30 01:11:22 UTC
Hi Frank,
I just got this repsonse.

No it is not possible to add mime-types through the ui at this time.  The
mimetypes that appear in the Add attachment sections are hardcoded
into the template.

Scarab does attempt to set the mimetype based on file extension, so in
most
cases it is not necessary to manually set the mimetype.  The mapping is
specified in a configuration file, though, and it is not possible to
update that via the ui either.
Comment 10 Frank Schönheit 2002-10-31 10:24:19 UTC
Eric, thanks for the information.
In this case, if I understand it correctly, shouldn't the
configuration file be updated to properly recognize the OpenOffice.org
extensions?
Comment 11 Unknown 2002-10-31 22:30:06 UTC
Hi Frank,

Engineering has a couple more questions on this issue.

If the file 
extention is automatically 
interpretted?  Will they need to add MIME types?  If so, 
what is the list that they use today?

Thanks,
Eric
Comment 12 Frank Schönheit 2002-11-01 12:39:19 UTC
Eric, sorry, I am not clear about your question...?

What this bug is originally about is that users should be able to
attach an OpenOffice.org document to an IssueZilla bug, giving it a
mime type which would allow to be associated with OOo directly.
Currently, "application/vnd.sun.xml.writer" is rejected by IZ, and
"application/octet-stream" is too generic to be of real use.

If I understand your previous comment properly, there is a
configuration somewhere which decides which mime type to use
automatically, depending on the extension of the file. Did I
understand this wrong? If not, why is engineering asking about the
content of this configuraton? :)

Confused
Frank
Comment 13 Unknown 2002-11-01 21:20:26 UTC
Hi Frank,

Let me go back to engineering with your latest update & see if we can
clarify this.
I will follow up on this issue as soon as I get another engineering
update.
Thanks for you patience here. 
Eric
Comment 14 stx123 2002-11-05 13:12:28 UTC
Frank, just a note: this issue has been reassigned to you...
Comment 15 Frank Schönheit 2002-11-05 15:56:35 UTC
Stefan, thanks, I indeed did not notice this (from the Issuezilla
mails, I find it hard to distinguish the ones I get because I am the
submitter from the ones where I am the owner).

Eric: why? :) I am surely the last who can do anything about this, at
least in state NEW. So unless you decide this is a WONTFIX, INVALID,
or WORKSFORME (I doubt the latter :), it does not make sense to assign
the bug to me, sorry.
As I feel that we did reach neither WONTFIX nor INVALID, I assign this
back to you.
Comment 16 Frank Schönheit 2002-11-05 16:11:05 UTC
the general support@openoffice.org may be the more suitable owner ...
Comment 17 Unknown 2002-11-12 23:59:36 UTC
Frank - Can you provide a list of all the openoffice mime types you
would like to have included?

I am reassigning this issue to you as I am awaiting a your response. 
Please reassign back to support when you comment.

Action plan: Wait for a response.

Timeframe: Upon response.
Comment 18 Frank Schönheit 2002-11-13 12:13:47 UTC
application/vnd.sun.xml.calc - OpenOffice.org Spreadsheet
application/vnd.sun.xml.chart - OpenOffice.org Chart
application/vnd.sun.xml.draw - OpenOffice.org Draw
application/vnd.sun.xml.impress - OpenOffice.org Presentation
application/vnd.sun.xml.math - OpenOffice.org Formula
application/vnd.sun.xml.writer - OpenOffice.org Text Document
application/vnd.sun.xml.writer.global - OpenOffice.org Master Document
Comment 19 Unknown 2002-11-13 17:47:41 UTC
Frank, thanks for the feedback, I will pass this along to our
engineers.  In the future, when you reply to a collab support rep,
please use the generic (support@oo.o) email address.  That way, our
entire support team can identify it as our issue.

Action Plan: Update the internal issue with this new information.

Timeframe: Update this issue in one week.
Comment 20 lsuarezpotts 2002-11-14 07:48:40 UTC
Brian,
This issue is particularly sensitive and should be given some
priority. Let me know what I can do.
Louis 
Comment 21 Frank Schönheit 2002-11-14 08:03:13 UTC
> In the future, when you reply to a collab support rep,
> please use the generic (support@oo.o) email address

will do, sorry.
Comment 22 lsuarezpotts 2002-11-14 08:26:11 UTC
*** Issue 6937 has been marked as a duplicate of this issue. ***
Comment 23 stx123 2002-11-14 09:08:58 UTC
Louis, raised the priority: P4 -> P3
I wasn't aware of the duplicates.
Comment 24 Frank Schönheit 2002-11-14 10:29:13 UTC
transfering the link from issue 6937:
http://framework.openoffice.org/documentation/mimetypes/mimetypes.html

the list of mime types there is far more comprehensive than what I
wrote above. 
Comment 25 Unknown 2002-12-31 07:29:54 UTC
This is the list of OO mime types that have been added to the Scarab
product:

application/vnd.sun.xml.writer sxw
application/vnd.sun.xml.writer.template stw
application/vnd.sun.xml.writer.global sxg
application/vnd.sun.xml.calc sxc
application/vnd.sun.xml.calc.template stc
application/vnd.sun.xml.impress sxi
application/vnd.sun.xml.impress.template sti
application/vnd.sun.xml.draw sxd
application/vnd.sun.xml.draw.template std
application/vnd.sun.xml.math sxm
application/vnd.stardivision.writer sdw vor
application/vnd.stardivision.writer-global sgl
application/vnd.stardivision.calc sdc
application/vnd.stardivision.impress sdd sdp
application/vnd.stardivision.draw sda
application/vnd.stardivision.math smf

Scarab is still in the process of having these mime types completely
incorporated.  Once, it has been completely updated with these new
mime types, I will close this issue.

Timeframe: Update by 01/03/03.
Comment 26 Unknown 2003-01-03 02:37:17 UTC
All the appropriate OOo mime types have been added to the scarab
product.  As such, closing this issue with a "resolved-later" status.
Comment 27 Frank Schönheit 2003-01-06 11:16:12 UTC
I am _really_ eager to see this Scarab working some day - 'til now,
it's somewhat unsatisfying to see these "later" resolutions, but okay ....

Thanks, anyway.
Comment 28 lohmaier 2003-02-16 21:48:38 UTC
I reopen this issue to make sure that not only OOos mime-types are
added to scarab, but the Microsoft-Office ones as well.

If this work is already done, sorry for the inconvenience. But I think
that asking before the new system is intruduced is better than having
to wait until the next update...
Comment 29 diane 2003-02-17 02:16:15 UTC
*** Issue 598 has been marked as a duplicate of this issue. ***
Comment 30 Unknown 2003-02-18 23:51:15 UTC
msoffice types are included in scarab.
Comment 31 michael.bemmer 2003-03-24 08:22:28 UTC
As agreed by Louis I will close these resolved fixed support-owned issues now.
If you have trouble with that, please re-open the issue.
Comment 32 michael.bemmer 2003-03-24 08:26:56 UTC
As agreed by Louis I will close these resolved fixed support-owned issues now.
If you have trouble with that, please re-open the issue.
Comment 33 Frank Schönheit 2003-08-19 08:01:33 UTC
re-opening it ('cause the issue again came up in the mailing lists).

This issue is *not* FIXED, at most, it's RESOLVED LATER.

Saying my ob-clause, again: It's really unsatisfying to see all these
issues being resolved as LATER - this is something which happened for
*months* (if not years) to all RFE's, with pointing to the famous
succcessor Scarab.

Anyway, somebody please resolve this as LATER, instead of FIXED, so
that the real state is reflected, and that people have a better chance
finding it.
Comment 34 lsuarezpotts 2003-08-19 08:42:57 UTC
fs, do you want to help us work on the upgrade site, 2.6? 
if so, let me know directly.
louis.
Comment 35 diane 2003-11-18 21:40:47 UTC
*** Issue 22490 has been marked as a duplicate of this issue. ***
Comment 36 diane 2003-11-19 12:08:44 UTC
*** Issue 12204 has been marked as a duplicate of this issue. ***
Comment 37 Unknown 2007-03-07 17:59:17 UTC
Setting milestone as 'CEE Consid-future' and adding PT marker to SWB

Regards,
Karishma
Support Operations
Comment 38 Unknown 2009-01-23 07:45:08 UTC
CollabNet Support is currently reviewing the issues under Resolved-Later. If the
issues are fixed currently in any of the present CEE releases, then it will be
marked as Resolved-Fixed.

There might be a few issues which might not be in our future roadmap which might
be closed as Wontfix unless it does not lie under any custom request.
Comment 39 Unknown 2009-01-23 07:46:37 UTC
This is available in PT
Comment 40 Unknown 2009-01-23 11:19:12 UTC
Setting The TM