Issue 9607 - Inserts incorrect number of columns
Summary: Inserts incorrect number of columns
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC2
Hardware: PC Windows 2000
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
: 9692 (view as issue list)
Depends on:
Reported: 2002-11-28 04:52 UTC by Unknown
Modified: 2017-05-20 11:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-11-28 04:52:39 UTC
I use Win2000

Steps to reproduce the bug

1) Start a new text document in OOo Writer
2) Go to menu Insert->Table. Table dialog will pop up
3) Change number of Rows to 3,276. Leave the number of Columns at 5.
4) Click OK.
5) Put the cursor at cell A1 [1st row, 1st column]
6) Go to menu Format->Column->Insert. The Insert Columns dialog will pop up
7) Click OK. (this mean leave default value 1 in Amount and After in Position 

Result: this will take a while, but after insert column is done, there are 5 
columns inserted instead of 1.
Comment 1 Unknown 2002-11-30 22:21:05 UTC
I use Win NT, OOo 643C 
and there is no problem in my computer to insert one more column.

After I followed the steps to reproduce this issue, the result was:
first column was split into two column and others didn't change.
It showed six columns: two columns had narrower width and three 
columns had wider width.
Comment 2 Unknown 2002-12-01 03:11:17 UTC
I use Windows XP Professional Version 2002 with SP1, and OOo 643C
I could NOT replicate this bug. 

I followed all 7 steps of Tony, and got the same result what Wen-
chiao did: OOo split the first column into two equal-width columns. 
At last, there appeared 6 columns. (Wen-chiao: I suppose you got 4 
columns with wider width at the end and not 3Â…)

Anyway, it took a while but no problem occurred. 

It would be very useful if more people could check it under WIN2000. 
Could it be an OS-version-related bug?

(I use Intel Pentium III Processor, 450 MHz, and 128 MB of RAM)
Comment 3 Unknown 2002-12-02 03:26:39 UTC
I have replicated this bug on windows 2000 machine and I also tried 
to replicate it in Windows XP. But on Windows XP it works fine. 
In Windows 2000:
1) When I tried to insert 2 columns using same steps, it properly 
inserts two columns.
2) If the default settings is changed, that is if we change the 
number of columns value and again make it one then it inserts only 
one column.
3) When I did not change the no. of columns and just pressed ok to 
insert column dialogue, instead of adding 1 column it divides each 
column into two columns. It gives exactly twice the number of 
columns. For example for 5 columns it gives 10 columns after using 
insert column function to insert 1 column. I also noticed that it 
does not divide columns of all rows. It divides columns of nearly 
half of the rows.
4) I found that the bug cannot be replicated if the default setting 
for number of columns to be inserted is changed even once.

Comment 4 h.ilter 2002-12-03 13:03:23 UTC
*** Issue 9692 has been marked as a duplicate of this issue. ***
Comment 5 Unknown 2002-12-03 17:10:40 UTC
When I tried to replicate this bug on Windows XP, AMD 1500+ laptop 
using OOo 643C, I could replicate the bug successfully. Also I noted 
that when I insert columns with default settings it divides some of 
the rows.
For example.: I inserted table with 5 columns and 3276 rows. Then I 
inserted column with default setting. The result was it divided each 
column in two for first 2607 rows (i.e for first 2607 rows it made 
no. columns as 10) and for the rest of the rows it kept no. of 
columns as 5.

Comment 6 mci 2003-08-07 16:57:08 UTC
mci: changed version to ooo1.1rc2
reassigned to mci
changed status to confirmed->new
reproduceable in ooo1.1rc2
Comment 7 mci 2003-08-08 13:35:43 UTC
mci: between step 4) and 5) don't wait until writer inserted all rows,
     the effect only appears by inserting a column while writer is 
     appending the rows
     It seems that writer inserts the number of columns out of the 
mci: reassigned to

@ama: please dispatch the Issue
Comment 8 andreas.martens 2003-08-11 16:37:13 UTC
We've a limitation of 65000 cells in Writer tables and we wnat to
change this. I assume that the described behaviour is related to this
limitation and will be solved.
Comment 9 mci 2003-08-14 13:47:24 UTC
reassigned to 

because 5*3276=16380, this is a lot smaller than 65000...
I think the behaviour is NOT related to this limitation...
It appears by inserting columns while writer hasn't finished inserting 

@ama: please dispatch
      If you intend to fix this one together with the rework of the 
      table concept inside the writer please keep this Issue...
Comment 10 andreas.martens 2003-08-14 16:29:24 UTC
Yep, I didn't recognized that the problems occurs only if you insert
the column during the formatting. If you wait until the table is
formatted all works fine. So this cannot be a 65000 or whatever limit
problem. The insert column command seems to ask the uncomplete layout
where cells has to be inserted. Hmm, we've to look at this.
Comment 11 openoffice 2003-09-12 11:34:53 UTC
Comment 12 openoffice 2003-09-29 13:55:20 UTC
Comment 13 h.ilter 2003-09-30 11:48:50 UTC
According to the roadmap
( this issue was retargeted to
OOo Later.
Comment 14 Marcus 2017-05-20 11:25:01 UTC
Reset assigne to the default "".
Comment 15 Marcus 2017-05-20 11:26:00 UTC
Reset assigne to the default "".