Issue 14053 - pre-1.1 Import/Export crash bugs with test cases and stack dumps
Summary: pre-1.1 Import/Export crash bugs with test cases and stack dumps
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: dankegel
QA Contact: issues@sw
URL: http://kegel.com/openoffice
Keywords: crash
Depends on: 9470 12264 12627 12936 13233 14046 14074 16296 17046 17413
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 22:55 UTC by dankegel
Modified: 2013-08-07 14:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description dankegel 2003-05-03 22:55:12 UTC
This is a tracking bug for Writer crash bugs in
any version of OpenOffice earlier than 1.1 final
which are trivially reproducible by 
importing or exporting an accompanying test file
and which have attached symbolic stack tracebacks.
In other words, for brown-paper-bag import/export
crash bugs for which there is no excuse to not fix
them.  Please don't add a bug to this tracking bug
if there is any question about whether it's
reproducible, or if it doesn't actually cause
an unrecoverable error.
Comment 1 dankegel 2003-05-03 22:56:40 UTC
Adding issues 9470 12627 13233 which I have verified
and for which I have contributed stack tracebacks.
Comment 2 dankegel 2003-05-07 05:54:56 UTC
Reproduced issue 14074 crash, uploaded stack dump
Comment 3 dankegel 2003-05-13 05:59:02 UTC
Just adding issue 14046 and updating target...
Comment 4 dankegel 2003-05-13 08:30:25 UTC
Adding issue 12936.  Reproduced it in ooo1.1beta1, caught a wild
pointer with valgrind.  Woo woo!
Comment 5 dankegel 2003-05-13 09:02:45 UTC
added issue 12264
Comment 6 h.ilter 2003-05-13 11:13:29 UTC
HI->MRU: This issue depends on other issues with ms.doc bugdocs
Comment 7 michael.ruess 2003-05-16 16:43:53 UTC
This Issue does not describe a problem or bug with OpenOffice itself.
This was submitted for having a kind of query and thus a QA member as
owner of this does not make sense. reassigned to submitter.
Comment 8 dankegel 2003-05-25 17:48:17 UTC
Issue 14074 is a duplicate of issue 10826, so I'm adding 10826 to the
list.  I'm leaving the status as NEW since at least one of these issues
is still NEW as of today.
Comment 9 Martin Hollmichel 2003-06-16 15:52:48 UTC
mh->dan: i10826 has been set so target 2.0, so we can consider this
issue as fixed ?
Comment 10 dankegel 2003-06-16 16:57:48 UTC
Not sure yet, there may be a few more pre-1.1 crash bugs I want
to track with this.  I'll try to add them in the next few days.

Probably fair to mark this bug "STARTED" though, so I will.
Comment 11 caolanm 2003-07-03 11:03:57 UTC
cmc->dankegel: There are now only a handful of 1.1RC bugs open, and
we'd like to reduce this number even further :-). All the 1.1RC bugs
that this issue depends on are resolved. The unresolved one is 2.0. I
suggest you set this task to 2.0 and reset its target back to 1.1RC if
you determine a new 1.1 showstopper that you want to make this
dependent on.
Comment 12 dankegel 2003-07-05 18:28:37 UTC
Added issue 16296
Comment 13 dankegel 2003-07-10 07:11:09 UTC
OK, I guess they're all working for me as well as can be expected
for OOo 1.1 timeframe.  I'll reopen if more pop up.
Comment 14 dankegel 2003-07-23 03:00:30 UTC
Added issue 17046.
Comment 15 dankegel 2003-07-26 05:29:22 UTC
Added issue 17413
Comment 16 dankegel 2003-07-26 05:47:02 UTC
Added crash keyword.  Changed target to OOo 1.1.
Comment 17 stx123 2003-07-29 14:11:46 UTC
All blocking bugs for this issue 14053 have a target 1.1.1 or 2.0. I 
move the target to 1.1.1
Comment 18 utomo99 2003-10-15 07:02:36 UTC
Utomo> st
You forget to set 
http://www.openoffice.org/project/www/issues/show_bug.cgi?id=10826
it still 2.0. 

I think still some other bugs exist but not yet listed
Comment 19 dankegel 2003-10-15 15:26:55 UTC
10826 got set back to 2.0, I think.  

If you see other bugs that should be listed here, please
either add them or tell me about them, thanks...
Comment 20 michael.bemmer 2003-12-19 11:03:21 UTC
I re-target this one to OOo1.1.2 now, as we're approaching 1.1.1.
Comment 21 dankegel 2003-12-19 14:10:05 UTC
Since 10826 is targeted at 2.0, I'm removing it.
This issue is now moot, since all the issues it
depends on are closed, and 1.1 was released.
Comment 22 Martin Hollmichel 2006-04-04 20:51:15 UTC
close issue