Issue 20049 - Error 'An API call exited abonormaly'
Summary: Error 'An API call exited abonormaly'
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 1.1 RC4
Hardware: PC Windows 2000
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo, oooqa
: 52828 (view as issue list)
Depends on:
Reported: 2003-09-25 11:58 UTC by ramaral
Modified: 2017-05-20 11:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description ramaral 2003-09-25 11:58:33 UTC
When i try execute in a browser a link like that: 
Comment 1 utomo99 2003-10-07 06:32:48 UTC
please explain more about your problem, your info is not enough to
investigate the problem. thanks
Comment 2 ramaral 2003-10-07 10:06:14 UTC
The error occurs when the link have not a drive letter 

the test was made with this file Test.htm:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<a href="doc/Apagar.sxw">Apagar</a>

 When i execute \\Server\Test.htm and  call the link the error occurs
 When i execute z:\Test.htm and call the link every is ok

Comment 3 utomo99 2003-11-12 09:09:45 UTC
I think it is network map issue. and it is not writer issue. 
but framework issue.

Comment 4 flibby05 2004-03-12 11:20:43 UTC
>> When i try execute in a ______browser_______ a link like that: 
>> \\SERVER\Company\INTRANET\Impressos\mod.C-Comercial\C11-Fax.sxw

maxweber -> All:
I am confused. Is this really an OOo-Issue?

IMHO opinion this could be more a general HTML - browser-issue..

Comment 5 jgriffis123 2004-04-12 20:28:56 UTC
I get the same "API call exited abnormally" error when I try to open .doc 
or .xls files using IE. Mozilla and Netscape work fine. Regular http seems to 
work fine, but not https. 

I have duplicated this issue and have seen a ton of posts on this.  I have 
tried OOo 1.1.0 and the new 1.1.1.

Place a .doc file on a http webserver.  Try opening it via http link with IE. 
(of course only OOo is installed and IE knows to use OOo to open the doc).  
You should succeed in opening the doc.

Now enable https on that webserver and try the same thing.  You will recieve a 
grey screen with an error that pops up about "API CALL EXITED ABNORMALLY".  

It appears to me that SSL is not supported with OOo and IE.  Can anyone 
confirm or anyone have any additional info?
Comment 6 utomo99 2004-04-21 08:27:00 UTC
utomo > jgriffis123 
the https issue is different to this. 
I believe https issue already have another issue number. 

but I still not yet clear about this issue. 
please provide more info:
what is your server os ? 
how is the network configurations. 
is the server a map drive or not 
and other useful info. 

Please try using the latest OpenOffice 1.1.1 or maybe 1.1.2rc , you can 
download it from
many bug fixes and enhancements since your version and 1.1.1 . If the problem 
still happend in 1.1.1 please report back. 
It maybe not yet solve your Issue, but it worth to try.
Comment 7 h.ilter 2004-04-22 14:38:11 UTC
Reassigned to ES
Comment 8 eric.savary 2004-04-22 15:30:19 UTC
ES->ATR: looks like an ActiveX Plugin problem. Please evaluate.
Comment 9 atr 2004-04-22 15:39:40 UTC
ATR->MAV: Hi Mikhail, this bug is dublicate to hte inhouse issue 116132,
reported by UL. Please have a look.

Comment 10 mikhail.voytenko 2004-04-23 12:45:13 UTC
This issue is not really a duplicate of the internal bug since this issue is
about support of UNC URLs by ActiveX control.
Comment 11 christianjunker 2005-07-16 14:05:24 UTC
duplicate of 19510.

*** This issue has been marked as a duplicate of 19510 ***
Comment 12 mikhail.voytenko 2005-07-18 10:28:31 UTC
This issue is no duplicate to the issue 19510. There is still no support for UNC
Comment 13 mikhail.voytenko 2005-08-03 14:26:24 UTC
*** Issue 52828 has been marked as a duplicate of this issue. ***
Comment 14 Marcus 2017-05-20 11:22:12 UTC
Reset assigne to the default "".