Issue 95759 - docx/xlsx/pptx export filters
Summary: docx/xlsx/pptx export filters
Status: CLOSED DUPLICATE of issue 88355
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: DEV300_m33
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 114914 126423 126818 (view as issue list)
Depends on: 96320 96321 103017 96313 96316 96319
Blocks:
  Show dependency tree
 
Reported: 2008-11-02 10:12 UTC by kendy
Modified: 2019-07-23 22:17 UTC (History)
15 users (show)

See Also:
Issue Type: FEATURE
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description kendy 2008-11-02 10:12:03 UTC
To improve interoperability with MS Office 12, eventually we will need OOXML 
[or exactly docx/xslx/pptx ;-)] export.  Since OOXML is so similar to the old 
binary formats, and to aid maintenance & code re-use, we have started 
refactoring that code to implement both formats.  The start of the work is in 
CWS ooxml01.
Comment 1 aziem 2008-11-04 15:06:57 UTC
Similar/duplicate to issue 88355   	
Comment 2 Mathias_Bauer 2008-11-05 11:35:49 UTC
As no patch is attached, I changed the type to "feature".

If you are working on refactoring code, please make sure that you sync with the
existing code quite often, otherwise odds are high that integration would become
a nightmare.

I also would like to see the code "owners" involved in the refactoring decisions
(->cc'ed hbrinkm).

BTW: I doubt that such filters are necessary at all:

- the export will not be better than with the binary export (as it uses the same
code)
- as more applications can read the binary format, interop will always be better
using the binary formats
- Office12 will get ODF import anyway; this is the first time in history where
MS will support our file format! Why spoil this moment by doing the same old
slave work again.

So it will be a huge time investment and in the end OOo will have more code
without any benefit for our users. But of course it's everybody's own choice
where he wants to waste his resources. ;-)

And at least code refactoring to make it better is indeed worthwhile.
Comment 3 kendy 2008-11-09 09:30:15 UTC
mba: Sorry for the wrong issue type & thanks for the correction!

> And at least code refactoring to make it better is indeed worthwhile.

Yes, I believe so :-) - when the refactoring is in the stage that it is good
enough for OOXML, it will be trivial to create a new RTF export [which is very
much needed from what I know] using the refactored code [and share the base
between these filters].

hbrinkm: If you have time to look at the code, input is most appreciated!
Comment 4 openoffice 2008-11-11 10:33:40 UTC
kendy: 

Do you plan to refactor the code in sw/filter/ww8 or add an export in writerfilter?

I would prefer the latter, since our road map is to discard sw/filter/ww8
eventually.
Comment 5 daniel.rentz 2008-11-11 10:37:51 UTC
There are no features in OOo that require the OOXML format to be exported
instead of the binary formats, therefore I think such a filter is not needed at
all. But well...
Comment 6 kendy 2008-11-11 13:10:10 UTC
hbrinkm: So far I'm redesigning the export stuff in sw/source/filter/ww8.  I 
have split the monolithic all-in-one class SwWW8Writer into three [+ some 
abstraction above this, but in principle it's 3 ;-)]:

- one that takes care of writing to the stream(s)
- one that manages the logic of the export filter [like collecting various 
ID's, styles and stuff]
- and one that actually outputs the attributes, like actual sprms & things 
around it

When this is done, it is much simplier to move the code to writerfilter, 
because 'UNOizing' in incremental steps will be more easily achievable.

dr: I am involved mostly in the Writer part of the work; but from what I know, 
at least xls probably cannot handle the new 1024 column limit, while xlsx 
can...
Comment 7 kendy 2008-11-11 13:22:29 UTC
[Just a correction, not 1024, but 16384, apparently...]
Comment 8 daniel.rentz 2008-11-11 14:03:20 UTC
right, I missed the column count expansion :-/
Comment 9 kendy 2008-11-18 16:53:22 UTC
I've changed the dependencies so that we can up-stream the work in more 
CWSes.  CWS ooxml01 should be deleted from EIS.
Comment 10 eric.savary 2010-10-05 05:32:33 UTC
*** Issue 114914 has been marked as a duplicate of this issue. ***
Comment 11 oooforum (fr) 2015-07-24 17:11:30 UTC
*** Issue 126423 has been marked as a duplicate of this issue. ***
Comment 12 Marcus 2016-01-31 13:39:38 UTC
*** Issue 126818 has been marked as a duplicate of this issue. ***
Comment 13 Marcus 2017-05-20 11:01:00 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 14 oooforum (fr) 2019-07-23 19:12:43 UTC
According with
> Similar/duplicate to issue 88355

*** This issue has been marked as a duplicate of issue 88355 ***