Issue 124191 - Mac64 only: Mighty Mouse horizontal scrolling issue
Summary: Mac64 only: Mighty Mouse horizontal scrolling issue
Status: VERIFIED FIXED
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: 4.1.0
Hardware: Mac Mac OS X, all
: P3 Major with 2 votes (vote)
Target Milestone: 4.1.1
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords: regression
: 124803 124873 124878 124956 124993 TK_CI 125028 125053 125243 125339 (view as issue list)
Depends on:
Blocks: 124985
  Show dependency treegraph
 
Reported: 2014-02-05 21:47 UTC by Frantisek Erben
Modified: 2016-08-29 15:33 UTC (History)
19 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---
jsc: 4.1.1_release_blocker+


Attachments
Scrollbars blocked (117.37 KB, image/png)
2014-05-09 16:16 UTC, papayes
no flags Details
patch to be tested (2.73 KB, patch)
2014-05-19 15:05 UTC, hdu@apache.org
no flags Details | Diff
WIN8 (36.80 KB, image/png)
2014-07-10 08:09 UTC, papayes
no flags Details
OsX (75.64 KB, image/png)
2014-07-10 08:10 UTC, papayes
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Frantisek Erben 2014-02-05 21:47:17 UTC
Reproduce:
Horizontal scroll using MightyMouse (no scrollbars but using active surface of MightyMouse) to left at column AAA and try to return back at column A.

Current state:
Impossible return back column A – spreadsheet move to column AMJ any and unable to move to A using MightyMouse active surface.

Wanted state:
Return back to column A via MightyMouse.

Workaround:
Use horizontal scrollbars.

Additional info:
Unable to reproduce on AOO 4.1 Mac32.
Generaly horizontal scrolling works fine between columns A and AAA, crossing AAA column or any similar border, evoke this bug.
Comment 1 papayes 2014-05-09 16:16:37 UTC
Created attachment 83366 [details]
Scrollbars blocked
Comment 2 papayes 2014-05-09 16:21:15 UTC
(In reply to papayes from comment #1)
> Created attachment 83366 [details]
> Scrollbars blocked

Hello,
only with mac OsX 10.9.2 and AOO 4.1.0
 
a regression as evidenced by the scrolling effect of the Apple mouse or trackpad, more easily reproducible by the following procedure:
  open a new document Calc
  cmd + right arrow key
and / or
cmd + down arrow key
  2 scrollbars are blocked
and can not be moved with the mouse (or the trackpad)

Only on Mac OS. Scrollbars WIN 7 and 8 , OpenSuse or Debian 7 are active ( with Ctrl +...).
Not reproduced on AOO 4.0.1
Workaround: cmd + left arrow key
cmd + up arrow key

Curious!
Comment 3 tintin60 2014-05-09 16:48:25 UTC
Hi,

I confirm.

Slts
Comment 4 Manfred 2014-05-12 12:25:40 UTC
same here

Trollius
Comment 5 Manfred 2014-05-13 16:20:33 UTC
all the same:

Horizontal scrolling to the left 
with Mouse or Trackpad
with Mac OS 10.x (x= 8 and 9) (7 and before?) 
and Calc since OO 4.1 (only 64 bit !) is impossible!

Window scrolls to right, if one want to scroll to left.

Issues to this problem:

124873
124803
124191
124878 (already marked as duplicate)

I hope, someone could repair this soon...

M
Comment 6 Los974 2014-05-19 13:58:56 UTC
Hi there, 
    I confirm this bug with the following setup : Macbook Pro 9,1 (mid-2012) running MacOSX 10.8.5, using the built-in trackpad.
    
    I had no issue with previous version of AOO. Scrolling up, down and right work as expected. But scrolling to the left produces the same effect as scrolling to the right. 

          Greetings, 

                     Los974
Comment 7 Ariel Constenla-Haile 2014-05-19 14:09:36 UTC
(In reply to Frantisek Erben from comment #0)
> Additional info:
> Unable to reproduce on AOO 4.1 Mac32.

Did you mean 4.0.1? This seems to contradict the other observations saying that 4.0.1 works fine and 4.1.0 not.

Looks like a regression introduced with the switch to 64 bit on 4.1.0, setting hdu on cc.
Comment 8 Frantisek Erben 2014-05-19 14:23:51 UTC
(In reply to Ariel Constenla-Haile from comment #7)
> (In reply to Frantisek Erben from comment #0)
> > Additional info:
> > Unable to reproduce on AOO 4.1 Mac32.
> 
> Did you mean 4.0.1? This seems to contradict the other observations saying
> that 4.0.1 works fine and 4.1.0 not.
> 
> Looks like a regression introduced with the switch to 64 bit on 4.1.0,
> setting hdu on cc.

When have been test it, there was available 4.1 Beta for Mac32.
So I've test it on 4.0.1 too -> the same result.

I can confirm that this bug is result 32->64 switch (regression).
Comment 9 hdu@apache.org 2014-05-19 15:05:56 UTC
Created attachment 83422 [details]
patch to be tested

I cannot reproduce the problem, but looking over the code I found two eventual causes. The patch fixes them and and cleans up related code:
- there was a typo in the scrollWheel() method where deltaY was checked in the deltaX path
- delta values where casted down from CGFloat (aka double) to float

If someone can reproduce the problem then it would be good to know if the patch solves it.
Comment 10 Alan Stanford 2014-05-19 16:46:16 UTC
I think I have a similar/identical problem with AOO 4.1.0.

I installed 4.1.0 last week as an update to 4.0.1 on my 2009 Macbook running Mavericks 10.9.3.  Since the AOO update, attempting to scroll left by wiping the Macbook trackpad to the left not only doesn't work - it causes a right scroll!  However, all other scroll functions work fine, i.e.  right scrolling using the trackpad and scrolling using the scroll bar or the arrow keys (with or without the cmd key) in both directions .

Appreciate your advice on what I should do, i.e. should I wait for the next version of AOO or is there a parameter in AOO 4.1.0 I should change?
Comment 11 hdu@apache.org 2014-05-20 09:20:15 UTC
A build containing the suggested patch is available at
   http://people.apache.org/~hdu/AOO_trunk_i124191.dmg
It would be interesting to know whether the problem is solved there.
Comment 12 tintin60 2014-05-20 09:44:43 UTC
Hi,

I checked.
Scroll bars don't block anymore.
No more back scrolling from column A.

It seems to operate correctly.

But...it is in English.

Thanks
Comment 13 Manfred 2014-05-20 10:05:41 UTC
(In reply to hdu@apache.org from comment #11)
> A build containing the suggested patch is available at
>    http://people.apache.org/~hdu/AOO_trunk_i124191.dmg
> It would be interesting to know whether the problem is solved there.


Tested - works! (OpenOffice 4.1.0 AOO420m1(Build:9800))

Scrolling works like aspected.
(10.9.3, 64bit)

(btw: better than with 4.0.1 -> the left-scrolling there was slower than the right-scrolling...)
Comment 14 hdu@apache.org 2014-05-20 14:56:46 UTC
Thanks for checking the test build! What happened was apparently when there was a positive dY and a negative dX and the typo caused that a negative number of scroll lines was calculated. When casted to an unsigned value this resulted in a huge positive number.

The bug was apparently introduced in 2010 by the changes for issue 90907 where then in since OOo 3.3. It was a regression then but how come it shows up now?
Comment 15 Thorsten Wagner 2014-05-20 22:19:22 UTC
For Migthy Mice The patch works as expected with Mac OS X 10.9.3, but the problem is not solved for all kinds of mice:

Mighty Mouse: ok
Trackpad:     ok
Wired Mouse:  not ok (old behaviour)
Comment 16 hdu@apache.org 2014-05-21 06:42:27 UTC
Ok, so the suggested patch seems to fix the problem.

(In reply to Thorsten Wagner from comment #15)
> Wired Mouse:  not ok (old behaviour)

https://discussions.apple.com/message/18703763 discusses something similar with one direction not working, which turns out to be a mechanical problem and the solution is to clean the scroll ball (http://support.apple.com/kb/TA26691) of this mouse.
Comment 17 SVN Robot 2014-05-21 06:51:36 UTC
"hdu" committed SVN revision 1596491 into trunk:
#i124191# fix horizontal scroll events on Mac
Comment 18 SVN Robot 2014-05-21 07:20:24 UTC
"hdu" committed SVN revision 1596494 into trunk:
#i124191# small cleanup for salframeview.mm
Comment 19 hdu@apache.org 2014-05-21 11:20:02 UTC
Fixed with the commits above.
Comment 20 Manfred 2014-05-21 12:05:31 UTC
Is it possible to make the patch work in other Languages with a Language-Pack?

Work every day with AOO, and this scroll-bug razz me.
Comment 21 jsc 2014-05-21 12:51:51 UTC
I have verified this issue on my MacBook (Macos 10.9.3) and it is fixed.

@Manfred: it is possible to use a recent libvcl.dylib from trunk and copy it in your 4.1.0 installation. It works and is probably the easiest way for you to solve this problem asap. I copied a new temporary vcl lib on the Apache people server for testing, please feel free to use it http://people.apache.org/~jsc/test/libvcl.dylib

Verified on trunk
Comment 22 Alan Stanford 2014-05-21 13:37:28 UTC
(In reply to hdu@apache.org from comment #11)
> A build containing the suggested patch is available at
>    http://people.apache.org/~hdu/AOO_trunk_i124191.dmg
> It would be interesting to know whether the problem is solved there.

I installed your patch just now and am delighted to tell you that it fixed my problem!  (If you remember I was having problems left scrolling using the trackpad on my 2009 Macbook after updating to AOO 4.1.0, with all other scroll functions operating OK).  Many thanks for your help.  I am delighted with your service.
Alan Stanford.
Comment 23 jsc 2014-05-21 15:01:18 UTC
I have replaced the new vcl lib with a new version because it contains a further fix that solves another problem on trunk. For normal usage I suggest o use the new version.
Comment 24 Manfred 2014-05-21 15:50:52 UTC
Thank you hdu und jsc.

Replaced the vcl lib (http://people.apache.org/~jsc/test/libvcl.dylib)
in Package / Mac OS- Folder

AND BE HAPPY !!!!

Great support guys!

Manfred
Comment 25 Cameron Auber 2014-05-22 04:55:28 UTC
*** Issue 124956 has been marked as a duplicate of this issue. ***
Comment 26 hdu@apache.org 2014-05-22 07:02:42 UTC
Thanks for the great feedback! I still wonder why the actual bug (the wrong signedness check) that got in four years ago (since OOo 3.3) has only manifested now...

Why it didn't show up here with my mice/trackpads is known now though: The devices are so sensitive that reported the scroll-deltas were quite small. This resulted in a zero value after the division which was then artificially set to one. So the problem with a negative number of scroll lines never happened.
Comment 27 hdu@apache.org 2014-05-26 12:17:14 UTC
*** Issue 124873 has been marked as a duplicate of this issue. ***
Comment 28 gazthewiz 2014-05-26 22:26:53 UTC
The patch fixes my problem (issue 124873).
Comment 29 hdu@apache.org 2014-05-27 15:55:19 UTC
*** Issue 124878 has been marked as a duplicate of this issue. ***
Comment 30 hdu@apache.org 2014-05-27 15:55:38 UTC
*** Issue 124803 has been marked as a duplicate of this issue. ***
Comment 31 hdu@apache.org 2014-06-02 12:02:37 UTC
*** Issue 125028 has been marked as a duplicate of this issue. ***
Comment 32 Ariel Constenla-Haile 2014-06-10 04:25:27 UTC
*** Issue 125005 has been marked as a duplicate of this issue. ***
Comment 33 jsc 2014-06-12 13:24:25 UTC
grant showstopper flag for AOO 4.1.1
Comment 34 SVN Robot 2014-06-13 09:55:18 UTC
"hdu" committed SVN revision 1602354 into branches/AOO410:
#i124191# fix horizontal scroll events on Mac
Comment 35 SVN Robot 2014-06-13 09:56:44 UTC
"hdu" committed SVN revision 1602355 into branches/AOO410:
#i124191# small cleanup for salframeview.mm
Comment 36 hdu@apache.org 2014-06-13 09:58:12 UTC
The fix has been merged for the AOO 4.1.1 target.
Comment 37 Marcus 2014-06-23 18:44:02 UTC
*** Issue 124993 has been marked as a duplicate of this issue. ***
Comment 38 papayes 2014-07-03 12:14:42 UTC
Hello,
macOsX 10.9.4
A00 4.1.1
AOO411m1(Build:9770)  -  Rev. 1603804
2014-06-12 17:05:56 (Thu, 12 Jun 2014)

The patch does not appear it was included in the first version of AOO 4.1.1

Scrollbars yet blocked.


Off topic:
https://cwiki.apache.org/confluence/display/OOOUSERS/Development+Snapshot+Builds
impossible to have .dmg all language...
Comment 39 jsc 2014-07-03 12:33:20 UTC
checked again in the latest milestone on MacOS 10.9.4

AOO411m1(Build:9770)  -  Rev. 1607011
2014-06-12 17:05:56 (Thu, 12 Jun 2014)

it works as expected now.
Comment 40 papayes 2014-07-10 06:54:05 UTC
Hello,
macOsX 10.9.4
A00 4.1.1
AOO411m2(Build:9771)  -  Rev. 1608452
2014-07-07 15:29:02 

The patch does not appear it was included in the second version of AOO 4.1.1

Scrollbars yet blocked.
Comment 41 hdu@apache.org 2014-07-10 07:07:34 UTC
(In reply to papayes from comment #40)
> Scrollbars yet blocked.

The original problem reported in comment 1: With some mice the scroll-wheels, scroll-balls or scroll-gestures didn't work. This one was fixed.

The strange behavior of scroll bars you are experiencing seems to be another bug that is not related to this one.

> The patch does not appear it was included in the second version of AOO 4.1.1

If people who experienced the original problem confirmed that the AOO411m2 fix doesn't work then it would be interesting to know whether the library replacement (see comment 21) still work.
Comment 42 papayes 2014-07-10 08:09:42 UTC
Created attachment 83669 [details]
WIN8
Comment 43 papayes 2014-07-10 08:10:37 UTC
Created attachment 83670 [details]
OsX
Comment 44 papayes 2014-07-10 08:12:45 UTC
Hello 
I put myself in the shoes of someone who downloads AOO 4.1.1 and did not install the patch, which will be the case for the majority of users!
I thought the 411 was made ​​to avoid being forced to download additional patches and extensions for proper operation.
The pach installed does not solve the problem for me!
See attachment "OsX"
Sorry! ...
Comment 45 Frantisek Erben 2014-07-10 09:02:35 UTC
Hello Papayes,
this is different/another problem then described in Description – please report it as another bug.

Thank you

+FE

(In reply to papayes from comment #44)
> Hello 
> I put myself in the shoes of someone who downloads AOO 4.1.1 and did not
> install the patch, which will be the case for the majority of users!
> I thought the 411 was made ​​to avoid being forced to download additional
> patches and extensions for proper operation.
> The pach installed does not solve the problem for me!
> See attachment "OsX"
> Sorry! ...
Comment 46 hdu@apache.org 2014-07-11 11:59:51 UTC
I split off the independent problem reported in comment into bug 125240...
Comment 47 Ariel Constenla-Haile 2014-07-12 14:51:36 UTC
*** Issue 125243 has been marked as a duplicate of this issue. ***
Comment 48 Ariel Constenla-Haile 2014-07-19 03:41:31 UTC
*** Issue 125053 has been marked as a duplicate of this issue. ***
Comment 49 Ariel Constenla-Haile 2014-08-09 01:15:02 UTC
*** Issue 125339 has been marked as a duplicate of this issue. ***
Comment 50 richard-house 2014-08-12 21:33:46 UTC
are there specific instructions for this fix?
Comment 51 hdu@apache.org 2014-08-21 09:44:12 UTC
> are there specific instructions for this fix?

No, it is supposed to just work fine in the new AOO 4.1.1 that is being released today.
Comment 52 Redfred Garett 2016-08-29 04:47:49 UTC
I haven't had that problem but something even more annoying started happening over the weekend.

Firstly - it would suddenly initiate both expose and dashboard - often simultaneously but sometimes just one or the other. There is no way that I either squeezed or pressed the scroll button when this happened so it wasn't just an accident, and has happened far too many times now to be a one off.

Secondly - the cursor would jump to the other side of the screen for no reason - usually jumping to the left.

Finally (and I doubt this is a problem with the mouse, but with everything else playing up who knows?) working in cubase vertical scrolling works fine but all horizontal scrolling is inverted. It's like steering a boat with an outboard, but less intuitive. There are no options within Cubase to alter this either. that I can see.

I have occasionally had the jumping cursor problem. I have no idea why it happens. So far it has not occurred often enough to get on my nerves. It has to be a mouse (or mouse firmware problem) since my one button BT mouse never did it.

Changelog: openoffice 4.1.1

 Bug Fixes
– "Read Error" with embedded images after saving in Writer
– *.docx import: import of overlapping bookmarks broken
– 2 scrollbars blocked at the ends of the sheet
– Add Catalan (ca) language
– Add language support for Valencian RACV (ca_XR)
– Add Valencian AVL (ca_XV) language
– Add Valencian RACV (ca_XR) language
– AOO opens Word .docx with wrong text alignment
– Bad SVG import with particular files
– Build no more possible with Xcode 5.1
– buildbot version 411 r1611634 crashes on attached document
– Bundle Catalan (ca) dictionary
– Bundle Catalan (Valencian) (ca-XR) dictionary
– Bundle Catalan (Valencian) (ca-XV) dictionary
– Comment/Annotation applies to wrong table selection
– conditional hidden paragraph does not update after textfield changes value
– conditional text field does not update view after changing variable
– CRASH when 'View – close sidebar' with Navigator active
– Crash when disabling sidebar view after undocking and closing sidebar
– CRASH when open edit mode copy of older document.odt version
– CRASH when scroll through very large and complex .odt
– Crash with sidebar
– Crash: after applying the comment arises the problem with using table
– cropping + scaling image in writer results in a blue rectangle
– CStringEqual can return true for non-equal c-strings
– Dictionaries updates right after installation
– doAccessibleAction(0) failed on combobox with dropdown
– Embedded GDI Metafiles replaced by "Read Error" box after File – Save
– embedded OLE object imported with wrong style from PPTX
– Embedded PNG Pictures replaced by "Read Error" box
– Export to SVG: Error when line contains arrow and text
– File – Versions – Always save a version on closing is not working
– Font color and shadow color cannot be different
– Font Effects not applied correctly
– Formular bar not updating
– German translation update
– German Windows: "unoinfo java" indicates UTF-16LE encoding, but encoding is not UTF-16
– Hangs when applying default format across multiple lines
– Help Text isn't right-aligned, in Hebrew/Arabic languages
– helpex Export::CopyFile is too slow
– Huge memory consumption for very large and complex .odt
– Huge memory usage with docs which contain many graphics
– Inherited style property "Space above/below Paragraph" lost for particular styles
– input fields are no longer considered as cell values
– Insert picture (from file) focus jumps to end of document
– Khmer (km) translation update
– layout differs in AOO 4.1.0 vs 4.0.1 (and previous)
– Left-mouse-down above text edit area crashes, "Index out of bounds"
– Line length miscalculated when character spacing is expanded
– Linked JPG image not preserved when exported to PDF with loss-less compression
– Linked SVG image embedded after save when automatic save has taken place
– Lithuanian (lt) translation update
– Mac and Java Oracle 1.7
– Mac64 only: Mighty Mouse horizontal scrolling issue
– named range with visibility condition can crash writer
– nbintegration: Blanks or Colons in path seem unsupported under windows
– No multimedia support in MacOSX
– Opening complex docx document takes several minutes (but succeeds)
– Opening some documents is much slower
– Picture loss on save
– Pootle damaged file
– Regression Textfield.user cant be deleted via Script
– remove custom allocator support in stlport-replacement headers
– remove obsoleted module-internal custom allocator in SAL
– reset formatting behind special formattings hangs AOO
– Send file as e-mail fails if AOO is in a path with spaces
– SVG export of a selected area causes the whole canvas to be exported
– Thai (th) translation update
– The Lookup Gesture looks up the wrong word
– Traditonal Chinese (zh-tw) translation from Pootle
– Update English dictionaries
– Update Hebrew (he) translation from Pootle
– update meta data
– Update PL (Polish) translation from Pootle
– Update Portuguese-Pt translation
– URL of linked PNG images wrong after save when automatic save has taken place
– Vietnamese (vi) translation
– WW6: outline not imported, thus no TOC entries displayed
– WW8: custom outline numbering has wrong first level style
– WW8: custom Outline numbering imported with wrong level assignment
– WW8: custom Outline Numbering is imported with wrong 2nd level setting
– WW8: imported TOC empty, due to paragraphs having "outline level" property
– WW8: outline imported instead of simple numbered list
– WW8: some headings have no outline level on import
– WW8: table of contents empty due to not assigned outline styles on import
– WW8: wrong style assignment for outline numbering imported
– [GTK] Scrollbars without steppers are buggy
– [SVG] svg node does not consider styles from a style element
* Additional Language Support
– Catalan (ca)
– Catalan (Valencian RACV) ca-XR)
– Catalan (Valencian AVL) (ca-XV)
* Updated translations
– German (de)
– Hebrew (he)
– Khmer (kh)
– Lithuanian (lt)
– Polish (pl)
– Portuguese
– (European) (pt-PT)
– Traditional Chinese (zh-tw)
– Thai (th)
– Vietnamese (vi)
* New and Updated Dictionaries
– Catalan (ca)
– Catalan (Valencian RACV) ca-XR)
– Catalan (Valencian AVL) (ca-XV)
* Updated Dictionaries
– English (en) Only the en-GB dictionary has been updated
– French (fr)
– Portuguese (European) (pt-PT)
– Russian (ru)
– Slovenian (sl) 


Thanks !!

https://www.linkedin.com/company/redgage-llc
Comment 53 orcmid 2016-08-29 14:11:39 UTC
(In reply to Redfred Garett from comment #52)
> I haven't had that problem but something even more annoying started
> happening over the weekend.
> 
> Firstly - it would suddenly initiate both expose and dashboard - often
> simultaneously but sometimes just one or the other. There is no way that I
> either squeezed or pressed the scroll button when this happened so it wasn't
> just an accident, and has happened far too many times now to be a one off.
> 
> Secondly - the cursor would jump to the other side of the screen for no
> reason - usually jumping to the left.
> 
> Finally (and I doubt this is a problem with the mouse, but with everything
> else playing up who knows?) working in cubase vertical scrolling works fine
> but all horizontal scrolling is inverted. It's like steering a boat with an
> outboard, but less intuitive. There are no options within Cubase to alter
> this either. that I can see.
> 
> I have occasionally had the jumping cursor problem. I have no idea why it
> happens. So far it has not occurred often enough to get on my nerves. It has
> to be a mouse (or mouse firmware problem) since my one button BT mouse never
> did it.
[ ... ]

Why did you copy the changelog for 4.1.1 instead of linking to it?

Is your Mac a laptop with a trackpad?

You may discover that the trackpad is sensitive to palm pressure on other parts of the laptop surface.  

Also, having a problem in Cubase suggests this is a system issue and not specific to Apache OpenOffice 4.1.1.

Please be specific about what happens with Apache OpenOffice exclusively.