Issue 121930 - Tracking Issue for Spell Checking Not Working
Summary: Tracking Issue for Spell Checking Not Working
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.4.1
Hardware: All All
: P3 Major (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL: http://www.openoffice.org/development...
Keywords:
: 120381 120454 120643 121095 121205 121617 121628 121635 121661 121663 121852 121879 121887 121891 121929 121993 122225 122299 122353 122415 122445 122646 123571 124043 124105 124159 124221 124258 124273 124546 124614 124739 124752 124775 124819 125073 125093 125252 125319 125341 125406 125442 125540 125541 125634 125686 125687 125842 126045 126046 126097 126153 126228 126299 126327 126340 126347 126359 126397 126418 126475 126491 126492 126525 126561 126657 126733 126737 126741 126745 126749 126774 126847 126940 126947 127062 127072 127101 127111 127132 127133 127159 127257 127319 127344 127361 127369 127374 127379 127385 127393 127394 127396 127403 127407 127417 127438 127458 127599 127603 127699 127728 127764 127785 127935 128004 128067 128147 128149 128177 128192 (view as issue list)
Depends on:
Blocks:
 
Reported: 2013-03-21 18:31 UTC by Rob Weir
Modified: 2019-09-09 10:44 UTC (History)
114 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Rob Weir 2013-03-21 18:31:31 UTC
Some users, when upgrading to AOO 3.4.1 experience a condition where spell checking does not work.  This appears to be related to the user profile issue:

https://issues.apache.org/ooo/show_bug.cgi?id=121625

The same solution described there appears to clear the problem, namely deleting or renaming the user profile directory.
Comment 1 Rob Weir 2013-03-21 18:36:09 UTC
*** Issue 121891 has been marked as a duplicate of this issue. ***
Comment 2 Rob Weir 2013-03-21 18:38:10 UTC
*** Issue 121879 has been marked as a duplicate of this issue. ***
Comment 3 Rob Weir 2013-03-21 18:39:39 UTC
*** Issue 121929 has been marked as a duplicate of this issue. ***
Comment 4 Ariel Constenla-Haile 2013-05-21 21:16:40 UTC
*** Issue 122353 has been marked as a duplicate of this issue. ***
Comment 5 anita 2013-05-22 08:19:25 UTC
I have had 3.4.1 installed for a long time now and the spell check error has only just happened. Does the resolution below still apply?



(In reply to comment #0)
> Some users, when upgrading to AOO 3.4.1 experience a condition where spell
> checking does not work.  This appears to be related to the user profile
> issue:
> 
> https://issues.apache.org/ooo/show_bug.cgi?id=121625
> 
> The same solution described there appears to clear the problem, namely
> deleting or renaming the user profile directory.
Comment 6 Ariel Constenla-Haile 2013-05-22 16:05:13 UTC
Removing Ed on Cc
Comment 7 Rob Weir 2013-06-03 20:12:43 UTC
*** Issue 122445 has been marked as a duplicate of this issue. ***
Comment 8 Rob Weir 2013-06-03 20:28:23 UTC
*** Issue 122415 has been marked as a duplicate of this issue. ***
Comment 9 Ariel Constenla-Haile 2013-06-05 14:21:47 UTC
*** Issue 121887 has been marked as a duplicate of this issue. ***
Comment 10 Ariel Constenla-Haile 2013-06-05 14:24:34 UTC
*** Issue 121993 has been marked as a duplicate of this issue. ***
Comment 11 Rainer Bielefeld 2014-01-05 08:09:33 UTC
*** Issue 120381 has been marked as a duplicate of this issue. ***
Comment 12 Rainer Bielefeld 2014-01-05 08:15:05 UTC
*** Issue 123612 has been marked as a duplicate of this issue. ***
Comment 13 Rainer Bielefeld 2014-01-05 08:16:33 UTC
*** Issue 122225 has been marked as a duplicate of this issue. ***
Comment 14 Rainer Bielefeld 2014-01-18 07:04:24 UTC
<http://www.openoffice.org/development/releases/3.4.1.html#AOO3.4.1ReleaseNotes-KnownIssues> for description and instructions.
Comment 15 Rainer Bielefeld 2014-02-01 07:52:31 UTC
*** Issue 124159 has been marked as a duplicate of this issue. ***
Comment 16 Rainer Bielefeld 2014-02-01 07:57:32 UTC
*** Issue 124105 has been marked as a duplicate of this issue. ***
Comment 17 Rainer Bielefeld 2014-02-12 07:03:43 UTC
*** Issue 124221 has been marked as a duplicate of this issue. ***
Comment 18 Rainer Bielefeld 2014-02-18 14:50:17 UTC
*** Issue 124258 has been marked as a duplicate of this issue. ***
Comment 19 Rainer Bielefeld 2014-02-21 06:07:27 UTC
*** Issue 124273 has been marked as a duplicate of this issue. ***
Comment 20 Rainer Bielefeld 2014-02-21 22:13:46 UTC
*** Issue 124290 has been marked as a duplicate of this issue. ***
Comment 21 Rainer Bielefeld 2014-03-04 05:20:28 UTC
*** Issue 123571 has been marked as a duplicate of this issue. ***
Comment 22 Ariel Constenla-Haile 2014-03-28 17:39:55 UTC
*** Issue 124546 has been marked as a duplicate of this issue. ***
Comment 23 Rainer Bielefeld 2014-04-06 07:15:42 UTC
*** Issue 124614 has been marked as a duplicate of this issue. ***
Comment 24 Rainer Bielefeld 2014-04-25 05:35:47 UTC
*** Issue 124739 has been marked as a duplicate of this issue. ***
Comment 25 Rainer Bielefeld 2014-04-28 05:05:55 UTC
*** Issue 124752 has been marked as a duplicate of this issue. ***
Comment 26 Rainer Bielefeld 2014-04-30 09:42:47 UTC
I remove Reporter of "Issue 122415 - Russian language for spell check does not show up" because of request in personal mail.
Comment 27 Rainer Bielefeld 2014-04-30 17:06:47 UTC
*** Issue 124775 has been marked as a duplicate of this issue. ***
Comment 28 Rainer Bielefeld 2014-05-05 05:02:14 UTC
*** Issue 124819 has been marked as a duplicate of this issue. ***
Comment 29 Ariel Constenla-Haile 2014-07-13 18:35:31 UTC
*** Issue 121205 has been marked as a duplicate of this issue. ***
Comment 30 Ariel Constenla-Haile 2014-07-13 18:36:29 UTC
*** Issue 122646 has been marked as a duplicate of this issue. ***
Comment 31 Ariel Constenla-Haile 2014-07-13 18:36:40 UTC
*** Issue 120643 has been marked as a duplicate of this issue. ***
Comment 32 Ariel Constenla-Haile 2014-07-13 18:36:46 UTC
*** Issue 120454 has been marked as a duplicate of this issue. ***
Comment 33 Ariel Constenla-Haile 2014-07-13 18:37:13 UTC
*** Issue 121095 has been marked as a duplicate of this issue. ***
Comment 34 Ariel Constenla-Haile 2014-07-13 18:39:53 UTC
*** Issue 121617 has been marked as a duplicate of this issue. ***
Comment 35 Ariel Constenla-Haile 2014-07-13 18:40:14 UTC
*** Issue 121628 has been marked as a duplicate of this issue. ***
Comment 36 Ariel Constenla-Haile 2014-07-13 18:40:25 UTC
*** Issue 121635 has been marked as a duplicate of this issue. ***
Comment 37 Ariel Constenla-Haile 2014-07-13 18:40:33 UTC
*** Issue 121661 has been marked as a duplicate of this issue. ***
Comment 38 Ariel Constenla-Haile 2014-07-13 18:40:41 UTC
*** Issue 121663 has been marked as a duplicate of this issue. ***
Comment 39 Ariel Constenla-Haile 2014-07-13 18:42:32 UTC
*** Issue 122299 has been marked as a duplicate of this issue. ***
Comment 40 Ariel Constenla-Haile 2014-07-13 18:42:38 UTC
*** Issue 124043 has been marked as a duplicate of this issue. ***
Comment 41 rvln 2014-07-13 18:47:11 UTC
I had the same problem and deleting the user directory solved the problem in Writer. There was only a strange artefact:

When the spellchecker was working reversely in Writer, it worked OK in my Outlook 2011. Now that I deleted the user directory and created a new one by running Writer, the spellchecker works OK in writer but works reversely in Outlook 2011.

With 'reversely' I mean that correctly spelled words are marked misspelled and vice-versa.

My Outlook version is 2011 (Build 15.4.3555.0308).
My Writer version is 4.1.0 AOO410m18(Build:9764)  -  Rev. 1589052
2014-04-22 11:43:54 (Di, 22 Apr 2014)
Comment 42 Ariel Constenla-Haile 2014-07-13 18:57:46 UTC
(In reply to rvln from comment #41)
> I had the same problem and deleting the user directory solved the problem in
> Writer. There was only a strange artefact:
> 
> When the spellchecker was working reversely in Writer, it worked OK in my
> Outlook 2011. Now that I deleted the user directory and created a new one by
> running Writer, the spellchecker works OK in writer but works reversely in
> Outlook 2011.
> 
> With 'reversely' I mean that correctly spelled words are marked misspelled
> and vice-versa.
> 
> My Outlook version is 2011 (Build 15.4.3555.0308).
> My Writer version is 4.1.0 AOO410m18(Build:9764)  -  Rev. 1589052
> 2014-04-22 11:43:54 (Di, 22 Apr 2014)

That's strange, because OpenOffice has no influence at all with spell checking inside Outlook, which - I assume - uses its own resources, while OpenOffice uses a third party library (Hunspell) with dictionaries installed as extensions; there is no way OpenOffice spell checking affects the behavior of other applications, like Outlook, and there is no way OpenOffice is influenced by changes in other applications (at least on Windows and Linux).
Comment 43 rvln 2014-07-13 19:13:17 UTC
> That's strange, because OpenOffice has no influence at all with spell
> checking inside Outlook, which - I assume - uses its own resources, while
> OpenOffice uses a third party library (Hunspell) with dictionaries installed
> as extensions; there is no way OpenOffice spell checking affects the
> behavior of other applications, like Outlook, and there is no way OpenOffice
> is influenced by changes in other applications (at least on Windows and
> Linux).

That IS strange; I was under the impression that spellchecking in other applications was a service of OpenOffice. I have no explanation then; I probably am mistaking somewhere.
Comment 44 Ariel Constenla-Haile 2014-07-14 13:57:17 UTC
*** Issue 125252 has been marked as a duplicate of this issue. ***
Comment 45 Ariel Constenla-Haile 2014-07-29 08:39:58 UTC
*** Issue 125319 has been marked as a duplicate of this issue. ***
Comment 46 Ariel Constenla-Haile 2014-08-01 17:48:11 UTC
*** Issue 125341 has been marked as a duplicate of this issue. ***
Comment 47 pieterbrueghel 2014-08-01 19:59:50 UTC
Can you explain how to rename or delete the user profile?
Comment 48 Ariel Constenla-Haile 2014-08-01 20:09:42 UTC
(In reply to pieterbrueghel from comment #47)
> Can you explain how to rename or delete the user profile?

The user profile is folder.
First, close OpenOffice and locate the folder, with the program you use to browse folders and files.
Once you find the folder, rename it, or delete it.

Detailed information can be found in https://forum.openoffice.org/en/forum/viewtopic.php?t=12426
Comment 49 Ariel Constenla-Haile 2014-08-01 20:14:45 UTC
(In reply to pieterbrueghel from comment #47)
> Can you explain how to rename or delete the user profile?

Also note that most users have reported that simply removing the sub-folders named "extensions" and "uno_packages" solved the bug, so try first these solution; if this does not work, rename/remove the whole user profile.
Comment 50 Ariel Constenla-Haile 2014-08-03 13:10:33 UTC
*** Issue 125073 has been marked as a duplicate of this issue. ***
Comment 51 Ariel Constenla-Haile 2014-08-11 21:25:47 UTC
*** Issue 125406 has been marked as a duplicate of this issue. ***
Comment 52 Ariel Constenla-Haile 2014-08-15 21:47:33 UTC
*** Issue 125442 has been marked as a duplicate of this issue. ***
Comment 53 Ariel Constenla-Haile 2014-08-31 01:16:31 UTC
*** Issue 121852 has been marked as a duplicate of this issue. ***
Comment 54 Ariel Constenla-Haile 2014-08-31 01:19:21 UTC
*** Issue 125540 has been marked as a duplicate of this issue. ***
Comment 55 Ariel Constenla-Haile 2014-08-31 01:20:14 UTC
*** Issue 125541 has been marked as a duplicate of this issue. ***
Comment 56 pieterbrueghel 2014-08-31 02:25:57 UTC
Can you please explain what the user profile directory is and how you change or delete it?
Comment 57 pieterbrueghel 2014-08-31 02:27:02 UTC
Can you please explain what the user profile is and how you change or delete it?(In reply to Rob Weir from comment #0)
> Some users, when upgrading to AOO 3.4.1 experience a condition where spell
> checking does not work.  This appears to be related to the user profile
> issue:
> 
> https://issues.apache.org/ooo/show_bug.cgi?id=121625
> 
> The same solution described there appears to clear the problem, namely
> deleting or renaming the user profile directory.
Comment 58 Ariel Constenla-Haile 2014-09-19 03:51:38 UTC
*** Issue 125093 has been marked as a duplicate of this issue. ***
Comment 59 Ariel Constenla-Haile 2014-09-19 03:57:35 UTC
*** Issue 125634 has been marked as a duplicate of this issue. ***
Comment 60 Ariel Constenla-Haile 2014-10-12 15:47:21 UTC
*** Issue 125686 has been marked as a duplicate of this issue. ***
Comment 61 oooforum (fr) 2014-10-26 11:10:01 UTC
*** Issue 125687 has been marked as a duplicate of this issue. ***
Comment 62 Ariel Constenla-Haile 2014-11-09 01:28:00 UTC
*** Issue 125842 has been marked as a duplicate of this issue. ***
Comment 63 oooforum (fr) 2015-01-19 08:29:44 UTC
*** Issue 126045 has been marked as a duplicate of this issue. ***
Comment 64 Keith N. McKenna 2015-01-19 15:03:04 UTC
*** Issue 126046 has been marked as a duplicate of this issue. ***
Comment 65 Keith N. McKenna 2015-02-11 04:49:53 UTC
*** Issue 126097 has been marked as a duplicate of this issue. ***
Comment 66 oooforum (fr) 2015-03-06 10:34:05 UTC
*** Issue 126153 has been marked as a duplicate of this issue. ***
Comment 67 oooforum (fr) 2015-04-08 08:37:51 UTC
*** Issue 126228 has been marked as a duplicate of this issue. ***
Comment 68 Keith N. McKenna 2015-05-08 22:09:53 UTC
*** Issue 126299 has been marked as a duplicate of this issue. ***
Comment 69 oooforum (fr) 2015-05-26 09:36:33 UTC
*** Issue 126327 has been marked as a duplicate of this issue. ***
Comment 70 Francis W Hutter 2015-05-26 11:04:49 UTC
how do you delete the profile I can't find it?
Comment 71 oooforum (fr) 2015-05-28 16:05:38 UTC
*** Issue 126340 has been marked as a duplicate of this issue. ***
Comment 72 oooforum (fr) 2015-05-28 16:06:54 UTC
(In reply to Francis W Hutter from comment #70)
> how do you delete the profile I can't find it?
See comment 48
Comment 73 Keith N. McKenna 2015-05-29 22:17:14 UTC
*** Issue 126347 has been marked as a duplicate of this issue. ***
Comment 74 oooforum (fr) 2015-06-09 14:14:14 UTC
*** Issue 126359 has been marked as a duplicate of this issue. ***
Comment 75 oooforum (fr) 2015-07-06 07:45:52 UTC
*** Issue 126397 has been marked as a duplicate of this issue. ***
Comment 76 oooforum (fr) 2015-07-22 07:20:53 UTC
*** Issue 126418 has been marked as a duplicate of this issue. ***
Comment 77 Keith N. McKenna 2015-08-17 17:18:57 UTC
*** Issue 126475 has been marked as a duplicate of this issue. ***
Comment 78 hferg81 2015-08-17 19:02:10 UTC
OK, I'm having this issue in version 4.1.1, not version 3.4.1, and I have no idea where the user profile directory is that I'm supposed to delete!
Comment 79 oooforum (fr) 2015-08-27 09:04:05 UTC
*** Issue 126491 has been marked as a duplicate of this issue. ***
Comment 80 Keith N. McKenna 2015-08-28 14:22:02 UTC
*** Issue 126492 has been marked as a duplicate of this issue. ***
Comment 81 Keith N. McKenna 2015-09-15 15:46:58 UTC
*** Issue 126525 has been marked as a duplicate of this issue. ***
Comment 82 oooforum (fr) 2015-09-29 13:56:29 UTC
*** Issue 126561 has been marked as a duplicate of this issue. ***
Comment 83 Keith N. McKenna 2015-11-15 20:01:04 UTC
*** Issue 126657 has been marked as a duplicate of this issue. ***
Comment 84 Keith N. McKenna 2015-12-13 01:40:24 UTC
*** Issue 126733 has been marked as a duplicate of this issue. ***
Comment 85 Keith N. McKenna 2015-12-15 21:38:48 UTC
*** Issue 126737 has been marked as a duplicate of this issue. ***
Comment 86 Keith N. McKenna 2015-12-18 14:08:13 UTC
*** Issue 126741 has been marked as a duplicate of this issue. ***
Comment 87 Keith N. McKenna 2015-12-21 04:24:57 UTC
*** Issue 126749 has been marked as a duplicate of this issue. ***
Comment 88 oooforum (fr) 2015-12-21 09:50:30 UTC
*** Issue 126745 has been marked as a duplicate of this issue. ***
Comment 89 oooforum (fr) 2016-01-05 17:18:38 UTC
*** Issue 126774 has been marked as a duplicate of this issue. ***
Comment 90 oooforum (fr) 2016-02-17 14:15:06 UTC
*** Issue 126847 has been marked as a duplicate of this issue. ***
Comment 91 Kay 2016-03-14 20:46:16 UTC
refer to issue 126762 for a tested patch. Target milestone 4.2

https://bz.apache.org/ooo/show_bug.cgi?id=126762
Comment 92 oooforum (fr) 2016-04-28 09:04:04 UTC
*** Issue 126940 has been marked as a duplicate of this issue. ***
Comment 93 orcmid 2016-05-01 22:58:39 UTC
*** Issue 126947 has been marked as a duplicate of this issue. ***
Comment 94 Keith N. McKenna 2016-08-03 20:50:11 UTC
*** Issue 127062 has been marked as a duplicate of this issue. ***
Comment 95 Keith N. McKenna 2016-08-14 03:20:22 UTC
*** Issue 127072 has been marked as a duplicate of this issue. ***
Comment 96 orcmid 2016-08-15 21:36:01 UTC
When some other work is completed over the current week, I am going to put my attention on creation of a downloadable tool that will reset the user profile on Windows.  Versions for other platforms can be based on that.  The end-user will not be required to find AppData under there account, and the tool will be very careful in establishing that it has found the right place.

This will not be comprehensive.  I.e., it will end up backing up some material that the user might want back.  We can work through second-order problems once we have the first-order difficulty in place.

There are two things that make this and other supplemental tools workable.

 1. The basic approach can be accomplished with a simple script, such as the kind now in beta test for applying a HotFix to Apache OpenOffice 4.1.2.

 2. Every installation of Apache OpenOffice 4.1.x has its own install of Python which can be used for more complicated utility functions when more functionality is required.

My target for having something in QA and beta testing is the end US Labor Day weekend, September 2-5.
Comment 97 orcmid 2016-08-24 16:48:04 UTC
(In reply to orcmid from comment #96)
> When some other work is completed over the current week, I am going to put
> my attention on creation of a downloadable tool that will reset the user
> profile on Windows.  Versions for other platforms can be based on that.  The
> end-user will not be required to find AppData under there account, and the
> tool will be very careful in establishing that it has found the right place.
> 
> This will not be comprehensive.  I.e., it will end up backing up some
> material that the user might want back.  We can work through second-order
> problems once we have the first-order difficulty in place.
> 
> There are two things that make this and other supplemental tools workable.
> 
>  1. The basic approach can be accomplished with a simple script, such as the
> kind now in beta test for applying a HotFix to Apache OpenOffice 4.1.2.
> 
>  2. Every installation of Apache OpenOffice 4.1.x has its own install of
> Python which can be used for more complicated utility functions when more
> functionality is required.
> 
> My target for having something in QA and beta testing is the end US Labor
> Day weekend, September 2-5.

The development of the tool for Windows versions of OpenOffice 4 is being tracked by the Task at Issue 127088.
Comment 98 Keith N. McKenna 2016-09-06 14:39:50 UTC
*** Issue 127101 has been marked as a duplicate of this issue. ***
Comment 99 oooforum (fr) 2016-09-14 07:17:57 UTC
*** Issue 127111 has been marked as a duplicate of this issue. ***
Comment 100 oooforum (fr) 2016-09-23 10:26:09 UTC
*** Issue 127132 has been marked as a duplicate of this issue. ***
Comment 101 Keith N. McKenna 2016-09-26 00:38:57 UTC
*** Issue 127133 has been marked as a duplicate of this issue. ***
Comment 102 John 2016-10-09 09:54:59 UTC
(In reply to orcmid from comment #96)
> When some other work is completed over the current week, I am going to put
> my attention on creation of a downloadable tool that will reset the user
> profile on Windows.  Versions for other platforms can be based on that.  The
> end-user will not be required to find AppData under there account, and the
> tool will be very careful in establishing that it has found the right place.
> 
When the user profile is reset by deleting or renaming ...\user, AOO creates a new default user profile and the user loses all their user dictionary words, word completion items etc, and, strangely, all their macros! See Issue 126952 - Resetting the profile loses all macros (and events too?) (and on upgrade or re-install?).

As I believe it is only necessary to create a new registrymodifications.xcu file I think that what is required is:

1  Close AOO 
2  Rename ...\user to ...\user-old
3  Start AOO - this creates a new ...\user
4  Close AOO
5  Copy the new registrymodifications.xcu file to ...\user_old
6  Delete ...\user
7  Rename ...\user_old to ...\user

Note:  AOO MUST be closed for Step 5. 

If AOO was started with the original, faulty registrymodifications.xcu, and registrymodifications.xcu is replaced, then when AOO closes, it writes back the original (plus any changes made while AOO was open) registrymodifications.xcu from memory and overwrites the new one.

Many forum posters have followed that technique successfully.  It is also documented in Hagar's [Tutorial] The OpenOffice User Profile at https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=12426

Also see Issue 127157 - Styles and Formatting window does not open - apparent cause is corrupted registrymodifications.xcu file.
Comment 103 hanya 2016-10-09 11:34:44 UTC
In my oppinion, the spell checker problem is not in registrymodifications.xcu, 
but the problem there in the remained configuration file in user/uno_packages/cache/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend directory.
If a configuration file which contains %origin% placeholder in an extension package, 
a file is created with expanded %origin% in the backend directory. 
It looks, if uninstallation or update of some extension package terminated by some 
issue, a generated file remained in backend. But the real contant of the extension 
package has been gone. So the remaiend file tells the dictionary file should be loaded. 
But if there is no dictionary file in the specified location in the configuration, 
all words are marked as wrong with red wave under line.

After revision 1762054, dictionary files not found are ignored. 
But still the broken configuration causes problems like spell checker not working.

Even if there is the way to reset registrymodification.xcu file, this problem would not be solved. 
Because there is no settings causes this problem in registrymodification.xcu file.

So, proposed way to fix this problem in user's profile is:
- Find configuration files which contains dictionary location in the configuration backedn directory mentioned above.
- Check existance of dictionary files listed in the found files.
- If a dictionary file is not exist anymore, omit the part in the file.
- Restart the office.
- Check dictionaries installed in the extension manager.

The files in the registry backend should be listed in backenddb.xml and configmgr.ini file. 
If we can remove files which contains the problem safely from the lists, we should do so.
But remained configuration files are not problem if there is no error in the file anymore.
Comment 104 orcmid 2016-10-09 15:21:00 UTC
(In reply to John from comment #102)
> (In reply to orcmid from comment #96)
> > When some other work is completed over the current week, I am going to put
> > my attention on creation of a downloadable tool that will reset the user
> > profile on Windows.  Versions for other platforms can be based on that.  The
> > end-user will not be required to find AppData under there account, and the
> > tool will be very careful in establishing that it has found the right place.
> > 
[ ... ]

Issue 127088 is what I created to actually work on that problem.  This Issue 121930 is a tracking issue.  It would be better to discuss the various considerations at Issue 127088.

Please note that I am no longer working on this problem.  I am in the process of retiring from community open-source work and attending to personal projects that I have been neglecting.
Comment 105 Keith N. McKenna 2016-10-13 22:15:29 UTC
*** Issue 127159 has been marked as a duplicate of this issue. ***
Comment 106 Ariel Constenla-Haile 2016-12-20 12:47:11 UTC
*** Issue 127257 has been marked as a duplicate of this issue. ***
Comment 107 jwtelman 2017-01-13 22:19:48 UTC
Almost every single word in my documents are underlined as though misspelled.
Comment 108 oooforum (fr) 2017-02-10 08:59:26 UTC
*** Issue 127319 has been marked as a duplicate of this issue. ***
Comment 109 oooforum (fr) 2017-03-03 09:25:00 UTC
*** Issue 127344 has been marked as a duplicate of this issue. ***
Comment 110 oooforum (fr) 2017-03-18 17:11:54 UTC
*** Issue 127361 has been marked as a duplicate of this issue. ***
Comment 111 oooforum (fr) 2017-03-23 08:52:11 UTC
*** Issue 127369 has been marked as a duplicate of this issue. ***
Comment 112 Marcus 2017-03-26 20:50:30 UTC
*** Issue 127374 has been marked as a duplicate of this issue. ***
Comment 113 Keith N. McKenna 2017-03-30 03:18:52 UTC
*** Issue 127379 has been marked as a duplicate of this issue. ***
Comment 114 oooforum (fr) 2017-04-07 07:57:58 UTC
*** Issue 127385 has been marked as a duplicate of this issue. ***
Comment 115 Keith N. McKenna 2017-04-24 21:20:50 UTC
*** Issue 127393 has been marked as a duplicate of this issue. ***
Comment 116 oooforum (fr) 2017-04-25 07:31:29 UTC
*** Issue 127394 has been marked as a duplicate of this issue. ***
Comment 117 pat71896 2017-04-25 18:53:57 UTC
If there is a solution, I am unable to find it.

This method of delivery, likely something Programmers understand, is Greek to me.

I cannot use Spell Check OR Thesaurus.

I have uninstalled and reinstalled 3 times from my download of AOO. I am too stupid to understand your 'solution', therefore, AOO is not functional for me.

Thanks for the thought, I am just not a programmer. 

Pat
Comment 118 pat71896 2017-04-25 18:57:27 UTC
OMG, that got sent to 50 people. 

One clue that I did see was to 'delete or renaming the user profile directory.' 

Do you mean the Windows profile dir? If I did that, all my files would have to be renamed. Right?

I could not find one in AOO.
Comment 119 oooforum (fr) 2017-04-26 08:37:19 UTC
If you don't understand given solutions or have some difficulties to did it, the best way is to use our end-users forum or mailing list.
http://www.openoffice.org/support/index.html
Comment 120 John 2017-04-26 09:47:34 UTC
(In reply to pat71896 from comment #118)
> OMG, that got sent to 50 people. 
> 
> One clue that I did see was to 'delete or renaming the user profile
> directory.' 
> 
> Do you mean the Windows profile dir? If I did that, all my files would have
> to be renamed. Right?
> 
> I could not find one in AOO.

Pat

Go to https://forum.openoffice.org/en/forum/viewforum.php?f=7 and search the forum with spellcheck.
Comment 121 oooforum (fr) 2017-04-26 10:06:21 UTC
*** Issue 127396 has been marked as a duplicate of this issue. ***
Comment 122 oooforum (fr) 2017-05-04 16:41:17 UTC
*** Issue 127403 has been marked as a duplicate of this issue. ***
Comment 123 Keith N. McKenna 2017-05-07 20:37:46 UTC
*** Issue 127407 has been marked as a duplicate of this issue. ***
Comment 124 oooforum (fr) 2017-05-19 12:31:44 UTC
*** Issue 127417 has been marked as a duplicate of this issue. ***
Comment 125 Marcus 2017-05-20 11:05:12 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 126 oooforum (fr) 2017-06-12 09:26:06 UTC
*** Issue 127438 has been marked as a duplicate of this issue. ***
Comment 127 Joe 2017-06-13 00:49:05 UTC
This is one of the most useless “help” sites I have ever seen. And most of the responses here are ridiculous. Aren't the developers here supposed to update these programs when a bug is found?
I don't know about anybody else but my spellcheck just stops working. Twice. So I just deleted the program and reinstalled it. Works fine. I didn't change any directory names, didn't add any remotely related programs, have no detectable virus, the spellcheck just stops working from what appears to be an internal problem. So fix it. Jeez!
Comment 128 Peter 2017-06-13 04:47:35 UTC
Fixing bugs on a 20 year old program is a challenge. If bug reports from users are inexperienced that makes it even harder to fix something.
As a general rule. If your problem can not reproduced in a laboratory environment, there is no chance for a fix.

So please, even if you are frustrated, (I am too regarding such bug reports as yours) start over and do things right. We are only a small core community that is working on evolving open office today.
Open Office needs your help, as much as you can provide. If you provide a good analysis which action has caused the issue, enlarges the chance we are able to fix the code.

If you just want that others do the job then other projects are more suited for you.


The minimal requirements are that we can reproduce the error in a laboratory environment.

Thank you for your attention. I hope for your understanding and support.

All the best
Peter
Comment 129 Peter 2017-06-13 07:03:25 UTC
I have checked with the community.
The usual root case of spell checking stopped working is that users do not shut down their systems probably. I check now if we want to harden open office against such behaviour or not.
If you always shut down your Operating system properly and still see the behaviour of spell check stops working please reach out again and we'll see what the issue is.

In general let your Operating system switch off prperly. It is insane not to do So!
Comment 130 John 2017-06-13 09:36:44 UTC
(In reply to Peter from comment #129)
> I have checked with the community.
> The usual root case of spell checking stopped working is that users do not
> shut down their systems probably.
Peter

I am one of the Forum Volunteers and the person who raised the spellcheck problem.  I did so because it is the most common problem reported in the User Forum - we sometimes get several posts a week! eg June 7, June 5, May 29, May 25, May 14 ...

We are GUESSING that the reason is because users do not shut down properly, probably slamming the laptop lid shut.  We have no knowledge.  (And, shouldn't the OS handle slamming the lid shut gracefully????)  

The reasons for our GUESS are:

1  We THINK, but we do not know, that the profile is the last thing to be written when AOO is closed.

2  We KNOW that when AOO closes, it continues to write files long after the "blue bar" has ceased to cross the bottom of the screen.  Users see the blue bar finish and think all is finished - it is not!  We THINK this is writing the profile after the document file has been saved.

My suggestion:

hanya wrote a python script which fixes spellcheck problems - see 
Spell checker "red wriggly lines" - beta test fix at https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=85529.  

If this script is included in the AOO download then the forum could tell people to run the script.  As it is today, we have to tell them to download the ZIP file containing the script, unzip the file, create a folder in the profile (case sensitive name!), install the script, and then run it.  

Alternatively, we tell them to rebuild the profile.  Just replacing the profile with the AOO default profile loses all the user customisation, AutoCorrect words, user dictionary etc, and all macros get lost. In fact we GUESS that the corruption lies only in C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user\config\ and suggest they replace all other folders except ...\config.

If you could give us any suggestions for debugging we will be very pleased to help you.  We unfortunately do not know enough about how the program works, or programming code to do a better diagnosis.

We recognise you are a small team who are doing a great job with very limited resources and wish there was a way we could help more.  Users volunteer that they find AOO is much more stable than LO - see Please redirect users to LibreOffice at https://forum.openoffice.org/en/forum/viewtopic.php?f=50&t=87149
Comment 131 Peter 2017-06-13 11:52:07 UTC
Thank you John. This sounded differently on the mailing list.
So I thought maybe no actions are needed, but you have convinced me otherwise.

I agree with you. Adding the "Beta - Script" sounds like an improvement.
But from your description we should look for solutions to awoid this data corruption. A "Won't Fix is definitly not an option.
I do not believe that a lot of people treat their system like there is no tomorrow. If you say you get these often. We need to come up with an approach.

Lets see what the mailing list thinks.
Comment 132 John 2017-06-13 13:06:11 UTC
Thank you.  

hanya describes his analysis of the problem and the rationale for his script in Comment 103 which I have copied below.  (NB.  hanya's reference to registrymodifications.xcu is in response to my Comment 102 where I wrongly thought the fault lay in registrymodifications.xcu)

In my [hanya] oppinion, the spell checker problem is not in registrymodifications.xcu, but the problem there in the remained configuration file in user/uno_packages/cache/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend directory.

If a configuration file which contains %origin% placeholder in an extension package, a file is created with expanded %origin% in the backend directory. 
It looks, if uninstallation or update of some extension package terminated by some issue, a generated file remained in backend. But the real contant of the extension package has been gone. So the remaiend file tells the dictionary file should be loaded. But if there is no dictionary file in the specified location in the configuration, all words are marked as wrong with red wave under line.

After revision 1762054, dictionary files not found are ignored. But still the broken configuration causes problems like spell checker not working.

Even if there is the way to reset registrymodification.xcu file, this problem would not be solved. 

Because there is no settings causes this problem in registrymodification.xcu file.

So, proposed way to fix this problem in user's profile is:

- Find configuration files which contains dictionary location in the configuration backedn directory mentioned above.
- Check existance of dictionary files listed in the found files.
- If a dictionary file is not exist anymore, omit the part in the file.
- Restart the office.
- Check dictionaries installed in the extension manager.

The files in the registry backend should be listed in backenddb.xml and configmgr.ini file. 

If we can remove files which contains the problem safely from the lists, we should do so.

But remained configuration files are not problem if there is no error in the file anymore.
Comment 133 oooforum (fr) 2017-06-30 08:02:18 UTC
*** Issue 127458 has been marked as a duplicate of this issue. ***
Comment 134 oooforum (fr) 2017-11-18 15:44:39 UTC
*** Issue 127599 has been marked as a duplicate of this issue. ***
Comment 135 John 2017-11-22 18:28:56 UTC
(In reply to hanya from comment #103)
hanya's python script has now been downloaded 330 times from https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=85529 and no person has reported any difficulty with it.  

There is a now sticky at the top of the Writer forum "[Solved] Spell Check Not Working (words red underlined)" which tells people how to fix spell check problems and directs them to the script. It has been viewed 1,200 times. 

Whereas spell check questions were the most frequent posts on the forum they are now extremely rare.

Can development please consider including hyanya's Python script in the AOO profile so that forum could be updated to tell users merely to run the script instead of having to create the (hidden!) folder, download and unzip the script, place it in the folder and run it.
Comment 136 oooforum (fr) 2017-11-23 19:35:47 UTC
*** Issue 127603 has been marked as a duplicate of this issue. ***
Comment 137 oooforum (fr) 2018-02-11 17:23:53 UTC
*** Issue 127699 has been marked as a duplicate of this issue. ***
Comment 138 oooforum (fr) 2018-03-09 10:37:40 UTC
*** Issue 127728 has been marked as a duplicate of this issue. ***
Comment 139 Keith N. McKenna 2018-05-01 14:39:31 UTC
*** Issue 127764 has been marked as a duplicate of this issue. ***
Comment 140 Keith N. McKenna 2018-05-02 20:31:01 UTC
(In reply to John from comment #135)
> (In reply to hanya from comment #103)
> hanya's python script has now been downloaded 330 times from
> https://forum.openoffice.org/en/forum/viewtopic.php?f=74&t=85529 and no
> person has reported any difficulty with it.  
> 
> There is a now sticky at the top of the Writer forum "[Solved] Spell Check
> Not Working (words red underlined)" which tells people how to fix spell
> check problems and directs them to the script. It has been viewed 1,200
> times. 
> 
> Whereas spell check questions were the most frequent posts on the forum they
> are now extremely rare.
> 
> Can development please consider including hyanya's Python script in the AOO
> profile so that forum could be updated to tell users merely to run the
> script instead of having to create the (hidden!) folder, download and unzip
> the script, place it in the folder and run it.

issue #127768 has been submitted as an RFE for this
Comment 141 Keith N. McKenna 2018-05-31 16:43:37 UTC
*** Issue 127785 has been marked as a duplicate of this issue. ***
Comment 142 Marcus 2018-11-12 19:33:19 UTC
*** Issue 127935 has been marked as a duplicate of this issue. ***
Comment 143 Keith N. McKenna 2019-01-11 23:37:21 UTC
*** Issue 128004 has been marked as a duplicate of this issue. ***
Comment 144 Ian Kirby 2019-02-27 20:45:04 UTC
4.1.6 Windows 10 still red underline of all words.
User dictionary can be constructed.
Ian.
Comment 145 Marcus 2019-03-19 21:51:15 UTC
*** Issue 128067 has been marked as a duplicate of this issue. ***
Comment 146 oooforum (fr) 2019-07-03 15:42:57 UTC
*** Issue 128147 has been marked as a duplicate of this issue. ***
Comment 147 oooforum (fr) 2019-07-08 15:05:15 UTC
*** Issue 128149 has been marked as a duplicate of this issue. ***
Comment 148 Keith N. McKenna 2019-08-17 12:43:58 UTC
*** Issue 128177 has been marked as a duplicate of this issue. ***
Comment 149 Peter 2019-09-09 10:44:10 UTC
*** Issue 128192 has been marked as a duplicate of this issue. ***